This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 873569 - [abrt] blueman-1.23-4.fc18: PulseAudio.py:214:card_cb:KeyError: 'bluez.path'
[abrt] blueman-1.23-4.fc18: PulseAudio.py:214:card_cb:KeyError: 'bluez.path'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:b777495c970740edbc57940c98f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-06 03:24 EST by Jiri Moskovcak
Modified: 2015-02-01 17:55 EST (History)
59 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 19:25:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: executable (23 bytes, text/plain)
2012-11-06 03:24 EST, Jiri Moskovcak
no flags Details
File: environ (1.50 KB, text/plain)
2012-11-06 03:25 EST, Jiri Moskovcak
no flags Details
File: smolt_data (3.74 KB, text/plain)
2012-11-06 03:25 EST, Jiri Moskovcak
no flags Details
File: core_backtrace (378 bytes, text/plain)
2012-11-06 03:25 EST, Jiri Moskovcak
no flags Details
alsa-info output (40.28 KB, text/plain)
2013-06-13 11:39 EDT, Jan Pokorný
no flags Details

  None (edit)
Description Jiri Moskovcak 2012-11-06 03:24:56 EST
Version-Release number of selected component:
blueman-1.23-4.fc18

Additional info:
libreport_version: 2.0.18.3.gf40e.dirty
abrt_version:   2.0.18.3.g7d865.dirty
cmdline:        /usr/bin/python /usr/bin/blueman-applet
kernel:         3.6.5-2.fc18.x86_64

backtrace:
:PulseAudio.py:214:card_cb:KeyError: 'bluez.path'
:
:Traceback (most recent call last):
:  File "_ctypes/callbacks.c", line 314, in 'calling callback function'
:  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 353, in __list_callback
:    info["handler"](entry_info, False)
:  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 522, in handler
:    callback(self.__card_info(entry_info))
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PulseAudio.py", line 214, in card_cb
:    m = self.loaded_modules[c["proplist"]["bluez.path"]]
:KeyError: 'bluez.path'
:
:Local variables in innermost frame:
:c: {'index': 1L, 'name': 'alsa_card.pci-0000_00_1b.0', 'owner_module': 5L, 'driver': 'module-alsa-card.c', 'profiles': [{'n_sources': 0L, 'priority': 6000L, 'n_sinks': 1L, 'name': 'output:analog-stereo', 'description': 'Analog Stereo Output'}, {'n_sources': 1L, 'priority': 6060L, 'n_sinks': 1L, 'name': 'output:analog-stereo+input:analog-stereo', 'description': 'Analog Stereo Duplex'}, {'n_sources': 1L, 'priority': 60L, 'n_sinks': 0L, 'name': 'input:analog-stereo', 'description': 'Analog Stereo Input'}, {'n_sources': 0L, 'priority': 0L, 'n_sinks': 0L, 'name': 'off', 'description': 'Off'}], 'active_profile': 'output:analog-stereo+input:analog-stereo', 'proplist': {'device.description': 'Built-in Audio', 'device.form_factor': 'internal', 'sysfs.path': '/devices/pci0000:00/0000:00:1b.0/sound/card0', 'alsa.card': '0', 'device.bus_path': 'pci-0000:00:1b.0', 'alsa.driver_name': 'snd_hda_intel', 'device.vendor.id': '8086', 'device.vendor.name': 'Intel Corporation', 'device.string': '0', 'device.bus': 'pci', 'alsa.card_name': 'HDA Intel', 'device.icon_name': 'audio-card-pci', 'device.product.name': '5 Series/3400 Series Chipset High Definition Audio', 'module-udev-detect.discovered': '1', 'alsa.long_card_name': 'HDA Intel at 0xf2420000 irq 45'}}
:pa_utils: <PulseAudioUtils object at 0x24d8410 (blueman+main+PulseAudioUtils+PulseAudioUtils at 0x251d240)>
:self: <blueman.plugins.applet.PulseAudio.PulseAudio object at 0x24d44d0>

Potential duplicate: bug 827646
Comment 1 Jiri Moskovcak 2012-11-06 03:24:59 EST
Created attachment 639184 [details]
File: executable
Comment 2 Jiri Moskovcak 2012-11-06 03:25:02 EST
Created attachment 639185 [details]
File: environ
Comment 3 Jiri Moskovcak 2012-11-06 03:25:04 EST
Created attachment 639186 [details]
File: smolt_data
Comment 4 Jiri Moskovcak 2012-11-06 03:25:05 EST
Created attachment 639187 [details]
File: core_backtrace
Comment 5 smanocch 2012-12-09 04:38:04 EST
Nothing particular, normal desktop usage

Package: blueman-1.23-4.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 6 Jiri Moskovcak 2013-01-21 09:26:45 EST
Description of problem:
It happens every time I plug in the headphones.

Version-Release number of selected component:
blueman-1.23-5.fc18

Additional info:
cmdline:        /usr/bin/python /usr/bin/blueman-applet
executable:     /usr/bin/blueman-applet
kernel:         3.7.2-201.fc18.x86_64
uid:            1000

Truncated backtrace:
PulseAudio.py:214:card_cb:KeyError: 'bluez.path'

Traceback (most recent call last):
  File "_ctypes/callbacks.c", line 314, in 'calling callback function'
  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 353, in __list_callback
    info["handler"](entry_info, False)
  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 522, in handler
    callback(self.__card_info(entry_info))
  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PulseAudio.py", line 214, in card_cb
    m = self.loaded_modules[c["proplist"]["bluez.path"]]
KeyError: 'bluez.path'

Local variables in innermost frame:
c: {'index': 1L, 'name': 'alsa_card.pci-0000_00_1b.0', 'owner_module': 5L, 'driver': 'module-alsa-card.c', 'profiles': [{'n_sources': 0L, 'priority': 6000L, 'n_sinks': 1L, 'name': 'output:analog-stereo', 'description': 'Analog Stereo Output'}, {'n_sources': 1L, 'priority': 6060L, 'n_sinks': 1L, 'name': 'output:analog-stereo+input:analog-stereo', 'description': 'Analog Stereo Duplex'}, {'n_sources': 1L, 'priority': 60L, 'n_sinks': 0L, 'name': 'input:analog-stereo', 'description': 'Analog Stereo Input'}, {'n_sources': 0L, 'priority': 0L, 'n_sinks': 0L, 'name': 'off', 'description': 'Off'}], 'active_profile': 'output:analog-stereo+input:analog-stereo', 'proplist': {'device.description': 'Built-in Audio', 'device.form_factor': 'internal', 'sysfs.path': '/devices/pci0000:00/0000:00:1b.0/sound/card0', 'alsa.card': '0', 'device.bus_path': 'pci-0000:00:1b.0', 'alsa.driver_name': 'snd_hda_intel', 'device.vendor.id': '8086', 'device.vendor.name': 'Intel Corporation', 'device.string': '0', 'device.bus': 'pci', 'alsa.card_name': 'HDA Intel MID', 'device.icon_name': 'audio-card-pci', 'device.product.id': '3b56', 'module-udev-detect.discovered': '1', 'alsa.long_card_name': 'HDA Intel MID at 0xf2420000 irq 43'}}
pa_utils: <PulseAudioUtils object at 0x14fc410 (blueman+main+PulseAudioUtils+PulseAudioUtils at 0x1534e80)>
self: <blueman.plugins.applet.PulseAudio.PulseAudio object at 0x14f84d0>
Comment 7 gatlibs 2013-02-05 21:47:32 EST
I have my laptop connected through H.D.M.I. to an external monitor (television). When I shut my laptop - with the power still on - both screens blank to black, but upon input (movement of mouse), the external monitor will recast the screen. I then get this error, every time.
Comment 8 Dave 2013-02-26 14:12:07 EST
Same problem here and I don't know if it's related to my PC all of the sudden having no sound after a recent update on fc17.

Any idea if this is ever going to be fixed, considering it's been an open bug for three months?
Comment 9 Sebastian Dyroff 2013-03-04 10:49:15 EST
Happens to me when I plug in an USB audio device. I also get lots of the following message in dmesg: systemd-udevd[19625]: Failed to set security context (null) for /dev/snd: File exists
Comment 10 adsam143@live.in 2013-03-08 08:55:54 EST
I just plugged in a headset.....also my stereo are giving harsh sound in fedora

Package: blueman-1.23-5.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 11 billyestuvoaqui 2013-03-09 05:38:49 EST
Just happened after plugging in my headphones.

Package: blueman-1.23-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 12 Sam 2013-03-09 19:33:50 EST
Plugged in headphones, notified of crash.  Audio came through the headphones fine.

Package: blueman-1.23-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 francisco.mancardi 2013-03-10 10:53:56 EDT
just inserted the headphones+mic plug

Package: blueman-1.23-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 14 Przemo 2013-03-10 14:09:02 EDT
Streaming audio over bluetooth. 

Package: blueman-1.23-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 15 casper 2013-03-12 02:08:41 EDT
При втыкивании штекера колонок

Package: blueman-1.23-5.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 16 Joe Wrigley 2013-03-13 05:52:11 EDT
unplugged headphones. similar problem when plugging it in

Package: blueman-1.23-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 17 casper 2013-03-14 11:44:06 EDT
Insert microphone and phones in notebook

Package: blueman-1.23-5.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 18 Brian Millett 2013-03-15 08:31:35 EDT
read the abrt report

Package: blueman-1.23-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 19 Homarano 2013-03-18 01:31:55 EDT
i attached the headphones to this gateway (intel b960) laptop when i received this error message. 

Package: blueman-1.23-5.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 20 Alberto 2013-04-03 12:01:23 EDT
Connect headphones to the audio output of my laptop

Package: blueman-1.23-5.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 21 Konstantin Svist 2013-05-10 13:28:56 EDT
Sometimes happens when plugging in HDMI cable with sound output to the TV
Comment 22 Konstantin Svist 2013-05-16 16:30:59 EDT
note: also showed up after setting audio to play at HDMI, then rebooting with HDMI unplugged (system didn't auto-switch to built-in speakers, so I did it manually)
Comment 23 ONURALP SEZER 2013-06-10 04:44:26 EDT

Package : blueman-1.23-6.fc19
Arch    : x86_64
OS Release : Fedora release 19 (Schrödinger’s Cat)
DE : XFCE

Problem still exist on new version too.When I plug on/off headphones or HDMI cable over the TV. Happen every time
Comment 24 Michael 2013-06-10 18:22:34 EDT
Description of problem:
Plugging in the headphones when system is running on battery power has caused this report.

Version-Release number of selected component:
blueman-1.23-5.fc18

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/blueman-applet
executable:     /usr/bin/blueman-applet
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
PulseAudio.py:214:card_cb:KeyError: 'bluez.path'

Traceback (most recent call last):
  File "_ctypes/callbacks.c", line 314, in 'calling callback function'
  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 353, in __list_callback
    info["handler"](entry_info, False)
  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 522, in handler
    callback(self.__card_info(entry_info))
  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PulseAudio.py", line 214, in card_cb
    m = self.loaded_modules[c["proplist"]["bluez.path"]]
KeyError: 'bluez.path'

Local variables in innermost frame:
c: {'index': 1L, 'name': 'alsa_card.pci-0000_00_14.2', 'owner_module': 5L, 'driver': 'module-alsa-card.c', 'profiles': [{'n_sources': 0L, 'priority': 6000L, 'n_sinks': 1L, 'name': 'output:analog-stereo', 'description': 'Analog Stereo Output'}, {'n_sources': 1L, 'priority': 6060L, 'n_sinks': 1L, 'name': 'output:analog-stereo+input:analog-stereo', 'description': 'Analog Stereo Duplex'}, {'n_sources': 1L, 'priority': 60L, 'n_sinks': 0L, 'name': 'input:analog-stereo', 'description': 'Analog Stereo Input'}, {'n_sources': 0L, 'priority': 0L, 'n_sinks': 0L, 'name': 'off', 'description': 'Off'}], 'active_profile': 'output:analog-stereo+input:analog-stereo', 'proplist': {'device.description': 'Built-in Audio', 'device.form_factor': 'internal', 'sysfs.path': '/devices/pci0000:00/0000:00:14.2/sound/card0', 'alsa.card': '0', 'device.bus_path': 'pci-0000:00:14.2', 'alsa.driver_name': 'snd_hda_intel', 'device.vendor.id': '1002', 'device.product.name': 'SBx00 Azalia (Intel HDA)', 'device.vendor.name': 'Advanced Micro Devices, Inc. [AMD/ATI]', 'device.string': '0', 'device.bus': 'pci', 'alsa.card_name': 'HDA ATI SB', 'device.icon_name': 'audio-card-pci', 'device.product.id': '4383', 'module-udev-detect.discovered': '1', 'alsa.long_card_name': 'HDA ATI SB at 0xfe6f8000 irq 16'}}
pa_utils: <PulseAudioUtils object at 0x1725a00 (blueman+main+PulseAudioUtils+PulseAudioUtils at 0x1765ce0)>
self: <blueman.plugins.applet.PulseAudio.PulseAudio object at 0x1718e90>
Comment 25 Clemens Eisserer 2013-06-11 18:10:26 EDT
me too - unplugging headphones triggered this crash.
Comment 26 Jan Pokorný 2013-06-13 11:39:31 EDT
Created attachment 760781 [details]
alsa-info output

In my case, this was triggered by pluggin headphones in, but only for
the first time (i.e., cannot trigger it anymore with subsequent
pull-in, pull-out).

$ rpm -q blueman pulseaudio
blueman-1.23-5.fc18.x86_64
pulseaudio-2.1-6.fc18.x86_64
Comment 27 Jan Pokorný 2013-06-17 10:30:00 EDT
re [comment 26]:

Haven't rebooted yet, when I try to run blueman-manager manually, I'll get:

> Connection to BlueZ failed
> 
> Bluez daemon is not running, blueman-manager cannot continue.
> This probably means that there were no Bluetooth adapters detected or Bluetooth
> daemon was not started.

while the output in the terminal looks like this:

$ blueman-manager 
> Loading configuration plugins
> Using gconf config backend
> _________
> Load (/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py:68)
> ['Services', 'PulseAudioProfile'] 
> _________
> __load_plugin (/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py:142)
> loading <class 'blueman.plugins.manager.Services.Services'> 
> _________
> __load_plugin (/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py:142)
> loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'> 
> _________
> pa_context_event (/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:306)
> 1 
> blueman-manager version 1.23 starting
> _________
> pa_context_event (/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:306)
> 2 
> _________
> on_bluez_name_owner_changed (/bin/blueman-manager:110)
> org.bluez owner changed to   
> _________
> pa_context_event (/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:306)
> 3 
> _________
> pa_context_event (/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:306)
> 4 
> _________
> on_pa_ready (/usr/lib/python2.7/site-packages/blueman/plugins/manager/PulseAudioProfile.py:45)
> connected 
> _________
> <lambda> (/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:318)
> 1
Comment 28 Eugene Kanter 2013-07-21 21:10:24 EDT
Desktop F19, inserted unconnected extension cable into line in, triggered the same ABRT signature.
Comment 29 Laurent Weislo 2013-07-27 14:24:14 EDT
Description of problem:
While plugin in my headphones

Version-Release number of selected component:
blueman-1.23-5.fc18

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/blueman-applet
executable:     /usr/bin/blueman-applet
kernel:         3.9.11-200.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
PulseAudio.py:214:card_cb:KeyError: 'bluez.path'

Traceback (most recent call last):
  File "_ctypes/callbacks.c", line 314, in 'calling callback function'
  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 353, in __list_callback
    info["handler"](entry_info, False)
  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 522, in handler
    callback(self.__card_info(entry_info))
  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PulseAudio.py", line 214, in card_cb
    m = self.loaded_modules[c["proplist"]["bluez.path"]]
KeyError: 'bluez.path'

Local variables in innermost frame:
c: {'index': 1L, 'name': 'alsa_card.pci-0000_00_14.2', 'owner_module': 5L, 'driver': 'module-alsa-card.c', 'profiles': [{'n_sources': 0L, 'priority': 6000L, 'n_sinks': 1L, 'name': 'output:analog-stereo', 'description': 'Analog Stereo Output'}, {'n_sources': 1L, 'priority': 6060L, 'n_sinks': 1L, 'name': 'output:analog-stereo+input:analog-stereo', 'description': 'Analog Stereo Duplex'}, {'n_sources': 1L, 'priority': 60L, 'n_sinks': 0L, 'name': 'input:analog-stereo', 'description': 'Analog Stereo Input'}, {'n_sources': 0L, 'priority': 0L, 'n_sinks': 0L, 'name': 'off', 'description': 'Off'}], 'active_profile': 'output:analog-stereo+input:analog-stereo', 'proplist': {'device.description': 'Built-in Audio', 'device.form_factor': 'internal', 'sysfs.path': '/devices/pci0000:00/0000:00:14.2/sound/card0', 'alsa.card': '0', 'device.bus_path': 'pci-0000:00:14.2', 'alsa.driver_name': 'snd_hda_intel', 'device.vendor.id': '1002', 'device.product.name': 'SBx00 Azalia (Intel HDA)', 'device.vendor.name': 'Advanced Micro Devices, Inc. [AMD/ATI]', 'device.string': '0', 'device.bus': 'pci', 'alsa.card_name': 'HDA ATI SB', 'device.icon_name': 'audio-card-pci', 'device.product.id': '4383', 'module-udev-detect.discovered': '1', 'alsa.long_card_name': 'HDA ATI SB at 0xfeb00000 irq 16'}}
pa_utils: <PulseAudioUtils object at 0x14d7f50 (blueman+main+PulseAudioUtils+PulseAudioUtils at 0x151c060)>
self: <blueman.plugins.applet.PulseAudio.PulseAudio object at 0x14dc0d0>
Comment 30 Pablo Rodríguez 2013-07-29 11:54:46 EDT
The same error when plugging headphones.

But what I cannot understand is why Fedora starts services for a bluetooth, when there is none available on my laptop (I disabled it on the BIOS).

Just in case it helps,


Pablo
Comment 31 Jan Pokorný 2013-11-05 11:50:24 EST
This seems to have stopped for me completely.

The only relevant and updated component now seems to be the kernel
(kernel-3.11.6-100.fc18.x86_64), the rest is as per [comment 26].
But my observation may be skewed.
Comment 32 Jan Pokorný 2013-11-06 04:58:54 EST
Actually, it is still there (checked after fresh reboot while sound jack
was connected, then disconnected -> reproduced).

Basically the same issue is [bug 878795].
Comment 33 Juan Manuel Rodriguez 2013-12-09 19:25:42 EST
Hello. The blueman package has been retired from Fedora. 

A new maintainer has forked blueman as the old version wasn't actively developed. You may reach the new repository at github [1], and re-file this bug if appropriate

I apologize for any issues the package has had over the time it was packaged in Fedora. If blueman gets Bluez 5 support, I'll consider repackaging it for Fedora. 

Regards, 

[1] https://github.com/cschramm/blueman

Note You need to log in before you can comment on or make changes to this bug.