Bug 873964 - Alt+G does not work under certain circumstances
Alt+G does not work under certain circumstances
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: 2.0
Assigned To: Alex Eng
Carlos Munoz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-07 01:01 EST by Hedda Peters
Modified: 2013-02-25 22:46 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121127-1451)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-11-07 01:01:08 EST
Description of problem:
The keyboard shortcut Alt+G does not work under certain circumstances.

Version-Release number of selected component (if applicable):
2.0

How reproducible:
always

Steps to Reproduce:
1. open any document in editor, place focus on one message
2. move focus away from browser by e.g. clicking on a different programm
3. move focus back to browser by clicking into the same message that had the focus before (or by any other means of moving focus back on browser without selecting a different string in editor)
4. press Alt+G 
  
Actual results:
Alt+G does not respond, mgsid is not being copied

Expected results:
Alt+G should work

Additional info:
A click into a different string, or moving around using keyboard shortcuts after putting focus back on browser will "resolve" the problem so that Alt+G works again. Seems that only using exact steps above breaks Alt+G.
Using FF 16.0.2
Comment 1 Alex Eng 2012-11-07 23:30:23 EST
Implemented fix in 2.0.X. 
See https://github.com/zanata/zanata/commit/476863834e0ff05b7a035282f60a22f4e4c42d5f
Comment 2 Ding-Yi Chen 2012-11-08 21:12:11 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121109-0034).
Comment 3 Sean Flanigan 2012-11-08 21:37:24 EST
Alex, would you please rename this bug to explain the "certain circumstances" now that you know what they are?
Comment 4 Sean Flanigan 2012-11-12 02:48:05 EST
Please test on 2.0.x.
Comment 5 Alex Eng 2012-11-27 00:43:18 EST
ALT+G only works when there's a focused editor.

This issues caused by focus lost when mouse clicking on other windows/browser.
When clicking back to editor's window, the focus state of the selected editor doesn't get updated.
Comment 6 Carlos Munoz 2012-11-27 01:06:55 EST
To clarify, Alt-G should work when focusing an editor. If the Zanata window is refocused by clicking somewhere else that is not the editor field, Alt-G should then do nothing.

Verified with version 2.0.3-SNAPSHOT (20121127-1451)
Comment 7 Hedda Peters 2012-11-27 01:16:34 EST
The editor is focused and responds to any other action though - just not Alt+G.

When following the above steps to move away and move back to the Zanata window, the editor is active and I can start typing, I can even use Ctrl+Alt+1 to use TM result - the only thing I cannot do is use Alt+G.

Note You need to log in before you can comment on or make changes to this bug.