This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 87414 - linux-2.4.20-oprofile.patch creates include/linux/workqueue.h but lacks it's implementation - prevents use of latest stable ALSA drivers
linux-2.4.20-oprofile.patch creates include/linux/workqueue.h but lacks it's ...
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-26 14:13 EST by Dan Berger
Modified: 2015-01-04 17:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 00:00:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Berger 2003-03-26 14:13:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030313 Galeon/1.3.3

Description of problem:
The summary pretty much says it all.  workqueue.h get's created - but the
implementation isn't - so any code that tries to use schedule_work (the latest
stable ALSA drivers, for example) compile correctly but fail to insmod due to
unresolved symbols.

I'm not sure what that patch does - I didn't spend much time looking at it - but
I can't see how it works if it actually relies on the primatives in workqueue.h


Version-Release number of selected component (if applicable):
kernel-2.4.20-2.54

How reproducible:
Always

Steps to Reproduce:
1. download the latest ALSA
2. build it
3. attempt to modprobe the acore/snd.o module
    

Actual Results:  unresolved symbol "schedule_work"

Additional info:

Moving workqueue.h out of the way allows ALSA to build and load into the kernel.

Note You need to log in before you can comment on or make changes to this bug.