Bug 874344 - RFE -- expose the cover option for wkhtmltopdf
RFE -- expose the cover option for wkhtmltopdf
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: 3.1
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-07 19:45 EST by Ruediger Landmann
Modified: 2013-02-05 22:40 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 22:40:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2012-11-07 19:45:37 EST
Description of problem:
wkhtmltopdf supports setting covers for PDF output; could we please get this supported at both the book- and brand- level? 

Version-Release number of selected component (if applicable):
3.0

Additional info:
We might want the PDF cover to match the EPUB cover by default; but maybe have this configurable if folks want different covers for the different formats?

There's an example of cover use here: http://madalgo.au.dk/~jakobt/wkhtmltoxdoc/wkhtmltopdf_0.10.0_rc2-doc.html
Comment 1 Jeff Fearn 2013-01-09 01:50:51 EST
This fix has been committed to the devel branch for inclusion in Publican 3.1.

Currently it uses the epub "front-large" image from the Book_Info file. The PUG has this set-up so it's easy to test.

Brands will be able to override the layout by overriding the css styles added to the bottom of common.css.

The default style is fairly bad so we'll need to harass someone with style skills :)
Comment 3 Ruediger Landmann 2013-01-10 18:11:34 EST
Verified that cover generation works in publican-3.0.0-0.fc17.t18.noarch, with a couple of glitches:

1. Cover content seems to be spread over two pages

2. Page numbering should exclude the cover itself
Comment 4 Ruediger Landmann 2013-01-10 20:09:08 EST
Also, can we get the header.html and footer.html exposed so that brands can customise this too please?
Comment 5 Ruediger Landmann 2013-01-11 00:40:22 EST
Works nicely in publican-3.0.0-0.fc17.t37.noarch -- thanks! :)
Comment 6 Jeff Fearn 2013-01-11 00:50:19 EST
1. The extra page is recto/verso thing, it needs to be there.

2. The tool doesn't support this unfortunately. Given there are numerous other bugs related to TOCs and page numbering we'll handle that as part of those bugs.

Added book_templates/ directory, brands can now add that directory and if they have files with the same name as the default directory dies they will override them.

Add pdf.css for customizing html-pdf CSS. Again adding a file to the brands css will override that.

This fix has been committed to the devel branch for inclusion in Publican 3.1.
Comment 7 xuezhi ma 2013-01-28 04:09:50 EST
Verify version:publican-3.1.0-0.el6eng  -> PASS

Verify steps:
1. Build a book with PDF format.
2. Check the cover of the PDF document.

Actual result:
There is a cover in PDF document and the cover with Header, Product-Version-Title, Subtitle and Authors

Note You need to log in before you can comment on or make changes to this bug.