Bug 874377 - "Virtualization hardware was detected but is disabled" miss in TUI when disable Intel/AMD virtuallization support in BIOS.
"Virtualization hardware was detected but is disabled" miss in TUI when disab...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-07 22:31 EST by shaochen
Modified: 2013-02-28 11:45 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-10.el6
Doc Type: Bug Fix
Doc Text:
Previously, an issue with imprecise kvm detection caused the TUI to fail to recognise when Intel/AMD virtualization support had been turned off in the BIOS. This has been fixed so that now both the TUI and the login screen show an error message if virtualization support is turned off.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:45:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shaochen 2012-11-07 22:31:11 EST
Description of problem:
"Virtualization hardware was detected but is disabled" miss in TUI when disable Intel/AMD virtuallization support in BIOS.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20121031.0.el6


Steps to Reproduce:
1. Disable Intel/AMD virtuallization support in BIOS.
2. Install RHEVH and reboot.
3. Login RHEV-H and focus on TUI.

Actual results:
1. "Virtualization hardware was detected but is disabled" can show in login screen, but miss in TUI.

Expected results:
"Virtualization hardware was detected but is disabled" can show in TUI and login screen.

Additional info:
No such issue in 6.2 & 6.3 GA version, so it is a regression bug.
Comment 3 Fabian Deutsch 2012-11-21 06:07:53 EST
http://gerrit.ovirt.org/9380

The kvm detection wasn't precise enough.
Comment 5 Fabian Deutsch 2012-11-21 07:30:54 EST
Tested as follows:

1. Install RHEVH with patch in VM (without nesting)
2. Boot RHEV-H
3. Focus on login prompt: Virt. hardware was not detected is on the screen
4. Login and focus on lower half: Virt hardware was not detected is on the screen
Comment 7 shaochen 2012-12-13 04:21:25 EST
Test version:
rhev-hypervisor6-6.4-20121206.0.el6

"Virtualization hardware was detected but is disabled" can show in TUI and login screen when disable Intel/AMD virtualization support in BIOS.
So the bug is fixed, change bug status to VERIFIED.
Comment 8 shaochen 2012-12-27 21:22:45 EST
Re-test with version rhev-hypervisor6-6.4-20121212.1.el6,

"Virtualization hardware was detected but is disabled" can show in TUI and login screen when disable Intel/AMD virtualization support in BIOS.
So the bug was fixed.
Comment 10 errata-xmlrpc 2013-02-28 11:45:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.