Bug 8751 - kfm and kpanel mysteriously disappear during remote X sessions
Summary: kfm and kpanel mysteriously disappear during remote X sessions
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-22 21:01 UTC by Simon Hill
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-06 16:07:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simon Hill 2000-01-22 21:01:42 UTC
I am running kdm on box1 (RH6.0) and connecting to it from box2
(RH6.1alpha) with

X -query box1

kfm will mysteriously crash, with kpanel following shortly thereafter. This
does not happen when running X/KDE locally on box1. I first thought it
might be some kind of auth problem, but even after putting both hosts in
xhost on both boxes, this still happens. I don't seem to be able to cause
this to happen, it usually happens when I turn my back for a few minutes,
although I just watched it happen a few minutes ago.

One thing I noticed is that DISPLAY is set to box2:0 rather than
box2.domain.net:0, but this is probably a seperate issue?

I am running kde-1.1.2 and XFree86-3.3.5

kdebase-1.1.2-11
XFree86-3.3.5-1.6.0 on box1
XFree86-3.3.5-17    on box2 (an alpha)

Comment 1 Simon Hill 2000-01-23 02:43:59 UTC
Caught it again and grabbed .xsession-errors. I doubt the audio stuff is
pertinent, but I have included it anyway.

maudio: Cannot open audio device.
PID could not get read.  (this line occurred a total of 12 times)
kwmsound: Failed connecting the audio server.
Please check manually if you can start kaudioserver.
kwm: X_ConfigureWindow(0x1c0001f): BadMatch (invalid parameter attributes)
kwm: X_ConfigureWindow(0x2c00475): BadMatch (invalid parameter attributes)
kwm: X_SetInputFocus(0xc00006): BadMatch (invalid parameter attributes)
/dev/sbdsp: Permission denied
/dev/sbdsp: Permission denied (these due to attempting mail notification)
/dev/sbdsp: Permission denied
kpanel: waiting for windowmanager
kpanel: ok, commencing initialization
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  62 (X_CopyArea)
  Resource id in failed request:  0x2800006
  Serial number of failed request:  5285
  Current serial number in output stream:  5287
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode:  62

Gdk-ERROR **: an x io error occurred
aborting...

Comment 2 Bernhard Rosenkraenzer 2000-02-06 16:07:59 UTC
Can't reproduce it with the current version.


Note You need to log in before you can comment on or make changes to this bug.