Bug 875461 - [abrt] util-linux-2.21.2-2.fc17: read_topology: Process /usr/bin/lscpu was killed by signal 8 (SIGFPE)
Summary: [abrt] util-linux-2.21.2-2.fc17: read_topology: Process /usr/bin/lscpu was ki...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f70918827f0b6536c1d81266a43...
: 850907 906143 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-11 12:06 UTC by masterf6
Modified: 2013-02-03 16:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-01 08:44:03 UTC
Type: ---


Attachments (Terms of Use)
File: core_backtrace (218 bytes, text/plain)
2012-11-11 12:06 UTC, masterf6
no flags Details
File: environ (2.94 KB, text/plain)
2012-11-11 12:06 UTC, masterf6
no flags Details
File: backtrace (35.08 KB, text/plain)
2012-11-11 12:06 UTC, masterf6
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: cgroup (130 bytes, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: smolt_data (2.19 KB, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: executable (14 bytes, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: maps (1.23 KB, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: dso_list (309 bytes, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: proc_pid_status (773 bytes, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: open_fds (90 bytes, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details
File: var_log_messages (145 bytes, text/plain)
2012-11-11 12:07 UTC, masterf6
no flags Details

Description masterf6 2012-11-11 12:06:47 UTC
Version-Release number of selected component:
util-linux-2.21.2-2.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        lscpu
crash_function: read_topology
kernel:         3.6.5-1.fc17.i686

truncated backtrace:
:Thread no. 1 (1 frames)
: #0 read_topology at lscpu.c:615

Comment 1 masterf6 2012-11-11 12:06:52 UTC
Created attachment 642777 [details]
File: core_backtrace

Comment 2 masterf6 2012-11-11 12:06:54 UTC
Created attachment 642778 [details]
File: environ

Comment 3 masterf6 2012-11-11 12:06:59 UTC
Created attachment 642779 [details]
File: backtrace

Comment 4 masterf6 2012-11-11 12:07:01 UTC
Created attachment 642780 [details]
File: limits

Comment 5 masterf6 2012-11-11 12:07:03 UTC
Created attachment 642781 [details]
File: cgroup

Comment 6 masterf6 2012-11-11 12:07:06 UTC
Created attachment 642782 [details]
File: smolt_data

Comment 7 masterf6 2012-11-11 12:07:09 UTC
Created attachment 642783 [details]
File: executable

Comment 8 masterf6 2012-11-11 12:07:11 UTC
Created attachment 642784 [details]
File: maps

Comment 9 masterf6 2012-11-11 12:07:14 UTC
Created attachment 642785 [details]
File: dso_list

Comment 10 masterf6 2012-11-11 12:07:16 UTC
Created attachment 642786 [details]
File: proc_pid_status

Comment 11 masterf6 2012-11-11 12:07:19 UTC
Created attachment 642787 [details]
File: open_fds

Comment 12 masterf6 2012-11-11 12:07:21 UTC
Created attachment 642788 [details]
File: var_log_messages

Comment 13 Karel Zak 2012-11-13 09:41:18 UTC
It would be nice to have /sys and /proc dump to reproduce the problem and test possible bugfix. Please use:

wget https://raw.github.com/karelzak/util-linux/master/tests/ts/lscpu/mk-input.sh
chmod +x mk-input.sh
./mk-input.sh lscpu-data-dump

and add the lscpu-data-dump.tar.gz to bugzilla. Thanks!

Comment 14 Karel Zak 2012-11-13 09:43:06 UTC
The bug is probably fixed by upstream commit d4bfa64d44e0515c59e5274d2384dedd9f9d4cc8. Fedora package will be fixed ASAP.

Comment 15 Fedora Update System 2012-11-16 11:46:08 UTC
util-linux-2.21.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/util-linux-2.21.2-3.fc17

Comment 16 Fedora Update System 2012-11-17 23:51:36 UTC
Package util-linux-2.21.2-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing util-linux-2.21.2-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18417/util-linux-2.21.2-3.fc17
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2012-12-01 08:44:05 UTC
util-linux-2.21.2-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Karel Zak 2013-02-01 16:44:25 UTC
*** Bug 906143 has been marked as a duplicate of this bug. ***

Comment 19 Karel Zak 2013-02-03 16:27:28 UTC
*** Bug 850907 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.