Bug 875519 - Default admonition titles appearing in the TOC of PDFs
Default admonition titles appearing in the TOC of PDFs
Status: CLOSED DUPLICATE of bug 846899
Product: Publican
Classification: Community
Component: publican (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
Depends On:
  Show dependency treegraph
Reported: 2012-11-11 16:23 EST by Jared MORGAN
Modified: 2015-08-09 21:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-11-11 21:06:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Build of the user guide where I detected the issue. (239.64 KB, application/pdf)
2012-11-11 16:23 EST, Jared MORGAN
no flags Details

  None (edit)
Description Jared MORGAN 2012-11-11 16:23:17 EST
Created attachment 643062 [details]
Build of the user guide where I detected the issue.

Description of problem:

Admonitions such as "Note" are being included in the TOC of PDF documents generated with wkhtmltopdf

Version-Release number of selected component (if applicable):

Publican 3.0

How reproducible:


Steps to Reproduce:
1. Check out https://github.com/jaredmorgs/USB_BT_Joystick_Center/
2. Build the document to PDF.
3. View Chapter 4 "Connect a Controller" (or look at attached PDF)
Actual results:

Admonition titles are included in the TOC. And for some reason, the Admonition titles are allowing the Procedures to be children of the Admonition.

Expected results:

Admonition titles are not included in the TOC and are not used as parent elements to the actual parent element they are a child of.

Additional info:

What you may observe is that Procedures are being included as well, which wasn't normal behavior in FOP.
Comment 1 Ruediger Landmann 2012-11-11 21:06:25 EST

*** This bug has been marked as a duplicate of bug 846899 ***

Note You need to log in before you can comment on or make changes to this bug.