Bug 875734 - [abrt] Zim-0.57-1.fc17: pageview.py:1567:get_indent:AssertionError: BUG: overlapping indent tags
[abrt] Zim-0.57-1.fc17: pageview.py:1567:get_indent:AssertionError: BUG: over...
Status: CLOSED DUPLICATE of bug 822638
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:5957e889e2a0bb052687dc85b8a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-12 08:52 EST by jibecfed
Modified: 2012-11-12 20:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 20:31:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: environ (1.38 KB, text/plain)
2012-11-12 08:52 EST, jibecfed
no flags Details
File: executable (12 bytes, text/plain)
2012-11-12 08:52 EST, jibecfed
no flags Details
File: smolt_data (3.12 KB, text/plain)
2012-11-12 08:52 EST, jibecfed
no flags Details
File: core_backtrace (461 bytes, text/plain)
2012-11-12 08:52 EST, jibecfed
no flags Details

  None (edit)
Description jibecfed 2012-11-12 08:52:39 EST
Version-Release number of selected component:
Zim-0.57-1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python /usr/bin/zim --ipc-server-main /tmp/zim-jb/zim-server-socket 30
kernel:         3.6.6-1.fc17.x86_64

backtrace:
:pageview.py:1567:get_indent:AssertionError: BUG: overlapping indent tags
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 3937, in do_end_of_line
:    buffer.set_bullet(newline, bullet)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 1071, in set_bullet
:    self._replace_bullet(iter, bullet)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 1078, in _replace_bullet
:    indent = self.get_indent(line)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 1567, in get_indent
:    assert len(tags) == 1, 'BUG: overlapping indent tags'
:AssertionError: BUG: overlapping indent tags
:
:Local variables in innermost frame:
:line: 14
:self: <TextBuffer object at 0x1b89d70 (zim+gui+pageview+TextBuffer at 0x27228b0)>
:iter: <GtkTextIter at 0x1cac9e0>
:tags: [<gtk.TextTag object at 0x1ba1690 (GtkTextTag at 0x27ce840)>, <gtk.TextTag object at 0x2767190 (GtkTextTag at 0x1efaa00)>]
Comment 1 jibecfed 2012-11-12 08:52:42 EST
Created attachment 643538 [details]
File: environ
Comment 2 jibecfed 2012-11-12 08:52:44 EST
Created attachment 643539 [details]
File: executable
Comment 3 jibecfed 2012-11-12 08:52:46 EST
Created attachment 643540 [details]
File: smolt_data
Comment 4 jibecfed 2012-11-12 08:52:51 EST
Created attachment 643541 [details]
File: core_backtrace
Comment 5 Robin Lee 2012-11-12 20:31:35 EST

*** This bug has been marked as a duplicate of bug 822638 ***

Note You need to log in before you can comment on or make changes to this bug.