Bug 8760 - How to mount SMB file system from NT server automatically?
How to mount SMB file system from NT server automatically?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-23 03:05 EST by Atanas Kolev
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-27 18:24:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atanas Kolev 2000-01-23 03:05:17 EST
How to mount SMB file system from NT server automatically?
I am mounting SMB file systems from NT server when user enters the X
session
(KDE). It is arranged in .bash_profile in users home directory:

# Mount my Home&Group at NT Server
smbmount //ntescl2/ugv73$ H -U ugv73 -P mypassword
smbmount //ntescl2/05057$ G -U ugv73 -P mypassword
smbmount //ntmlnz4/Public$ P -U ugv73 -P mypassword

When user logs out from X session SMB file systems are unmounted.
It is arranged in .bash_logout in users home directory:

# Unmount my Home&Group at NT Server
/usr/bin/smbumount /home/$USER/H
/usr/bin/smbumount /home/$USER/G
/usr/bin/smbumount /home/$USER/P

It was working fine in Red Hat 5.2 , but when upgraded to 6.1 i discovered
that command smbmount was changed. Now it is not clear how to mount
automatically that file systems.
Comment 1 Bill Nottingham 2000-01-24 00:13:59 EST
First, you'll need to make smbmount, smbumount setuid if
you want users mounts to work. Secondly, the
syntax for smbmount did change; you're probably
best off upgrading to samba-2.0.6, as samba-2.0.5
doesn't support mounting as a particular user, IIRC.
Comment 2 Atanas Kolev 2000-01-24 03:51:59 EST
P.S. Sorry i forgot to mention i have changed smbmount/smbumount setuid.

I have to renew my question because it is not correct that samba 2.0.5 is not
supporting mounting as a particular user. It accepts -U option and the problem
is that it not accepts -P (password) option and NT server is asking for
password interactively that means automatically mounting in script
is not possible.
Comment 3 Atanas Kolev 2000-01-24 03:56:59 EST
P.S. By the way - Where i can get samba 2.0.6 - it not appears to exists in Red
Hat 6.1 update ftp directory.
Comment 4 Atanas Kolev 2000-01-27 07:49:59 EST
The problem resolved:
I installed samba 2.0.6 - resolves the problem. I got it from ftp.samba.org
and ever more - it is possible to write NT server+directory, mounting point and
all options (username, password,etc.) in /etc/fstab file and do mount/umount
like just another file system.
Thanks.
Comment 5 Bill Nottingham 2000-01-27 18:24:59 EST
Oops, apologies for the slow response.

Samba-2.0.6 is in Raw Hide; you can get it from

ftp://ftp.redhat.com/pub/rawhide/

Note You need to log in before you can comment on or make changes to this bug.