Bug 876061 - [whql][wlk][block] windows 2003 can not generate dump file when hitting BSOD
[whql][wlk][block] windows 2003 can not generate dump file when hitting BSOD
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 02:55 EST by Mike Cao
Modified: 2013-02-21 05:42 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
In Red Hat Enterprise Linux 6.4 Beta, no dump file is generated when a Stop Error (or Blue Screen of Death) occurs on a Microsoft Windows Server 2003 guest.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:42:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Build46-2k3-FailTo-generate-dump (8.90 KB, image/png)
2012-11-22 04:59 EST, dawu
no flags Details
Build46-dump-saved-Notmyfault (18.47 KB, image/png)
2012-11-22 21:42 EST, dawu
no flags Details

  None (edit)
Description Mike Cao 2012-11-13 02:55:29 EST
Description of problem:
When windows server 2003 hit BSOD ,there is no generate dump file generated ,which cause "crashdump support test "job failed

Version-Release number of selected component (if applicable):
virtio-win-prewhql-43
win2k3 32/64

How reproducible:
100%

Steps to Reproduce:
1.Start VM with virtio-block
CLI:/usr/libexec/qemu-kvm -M rhel6.4.0 -m 2G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win2k3-32.raw,format=raw,if=none,id=drive-virtio0,boot=on,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet0,mac=00:11:1a:06:33:26,bus=pci.0,addr=0x4 -boot c -uuid 7768409c-460c-4deb-ba44-7570b2cab3c6 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/2k3-32-blk-43-new,server,nowait -mon chardev=111a,mode=readline -name win2k3-32-blk-new -vnc :1 -drive file=disk1.raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.raw,if=none,id=drive-virtio3,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.raw,if=none,id=drive-virtio4,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio
2.enable NMI crashdump or Run crashdump job in WLK1.6
3.(qemu)inject-nmi or waiting for WLK make the guest cause BSOD
  
Actual results:
no dump file generated

Expected results:
generate dump file

Additional info:
Tried on virtio-win-1.5.3.iso ,it can generate dump file successfully .mark this bug as regression
Comment 1 Vadim Rozenfeld 2012-11-22 03:11:36 EST
Hi Dawn,

Could you please try drivers from build 46 available at
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/46/win/virtio-win-prewhql-0.1.zip ?

Thank you,
Vadim.
Comment 2 dawu 2012-11-22 04:58:30 EST
(In reply to comment #1)
> Hi Dawn,
> 
> Could you please try drivers from build 46 available at
> http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/46/
> win/virtio-win-prewhql-0.1.zip ?
> 
> Thank you,
> Vadim.

Verified this bug on build 46 with manually testing (through NMI), steps is the same with comment #0

Actually Results:
Dump still fail to be generated after hitting BSOD.Please refer to the attachment "Build46-2k3-FailTo-generate-dump.png" for details.

Based on above, this issue haven't fixed yet, re-assign this bug.

Best Regards,
Dawn
Comment 3 dawu 2012-11-22 04:59:29 EST
Created attachment 649606 [details]
Build46-2k3-FailTo-generate-dump
Comment 4 Vadim Rozenfeld 2012-11-22 05:10:32 EST
that's strange,
could you try crashing the system with notmyfault utility available at
http://download.sysinternals.com/files/NotMyFault.zip ?

Thank you,
Vadim.
Comment 5 dawu 2012-11-22 21:41:00 EST
(In reply to comment #4)
> that's strange,
> could you try crashing the system with notmyfault utility available at
> http://download.sysinternals.com/files/NotMyFault.zip ?
> 
> Thank you,
> Vadim.

Hi Vadim,

Tried with notmyfault utility, dump can generate successfully, please refer to the attachment "Build46-dump-saved-Notmyfault.png".

Thanks!
Best Regards,
Dawn
Comment 6 dawu 2012-11-22 21:42:51 EST
Created attachment 650170 [details]
Build46-dump-saved-Notmyfault
Comment 7 Vadim Rozenfeld 2012-11-23 03:16:48 EST
good,
now can you please check that NMICrashDump is enabled?
http://support.microsoft.com/kb/927069

Thanks,
Vadim.
Comment 8 dawu 2012-11-23 03:31:05 EST
Hi Vadim,

I set the NMICrashDump as 1, so it had been enabled when I verified this issue by NMI in comment 2.
 
I'm not sure what kind of the method to trigger crash when doing whql, if it's not trigger by NMI, I think I can have a try for whql with build 46 instead of manually verification by NMI.

Best Regards,
Dawn
Comment 9 Vadim Rozenfeld 2012-11-23 04:51:53 EST
(In reply to comment #8)
> Hi Vadim,
> 
> I set the NMICrashDump as 1, so it had been enabled when I verified this
> issue by NMI in comment 2.
>  
> I'm not sure what kind of the method to trigger crash when doing whql, if

It is not NMI, Winwows should crash with MANUALLY_INITIATED_CRASH  bugcheck code

Cheers,
Vadim.

> it's not trigger by NMI, I think I can have a try for whql with build 46
> instead of manually verification by NMI.
> 
> Best Regards,
> Dawn
Comment 10 dawu 2012-11-23 05:08:10 EST
(In reply to comment #7)
> good,
> now can you please check that NMICrashDump is enabled?
> http://support.microsoft.com/kb/927069
> 
> Thanks,
> Vadim.

Hi Vadim,
Sorry for my mistake, I create NMICrashDump under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control instead of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl.

Tried with the correct setting, now dump can generate successfully with build 46,and we still will keep this bug open till related job pass for whql.

Thanks for your efforts!
Best Regards,
Dawn
Comment 11 Vadim Rozenfeld 2012-11-23 05:29:57 EST
(In reply to comment #10)
> (In reply to comment #7)
> > good,
> > now can you please check that NMICrashDump is enabled?
> > http://support.microsoft.com/kb/927069
> > 
> > Thanks,
> > Vadim.
> 
> Hi Vadim,
> Sorry for my mistake, I create NMICrashDump under
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control instead of
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl.
> 
No problem,
btw, crashdump test triggers the crash dump generation almost the same way as
keyboard does  
http://msdn.microsoft.com/en-us/library/windows/hardware/ff545499%28v=vs.85%29.aspx

Vadim.

> Tried with the correct setting, now dump can generate successfully with
> build 46,and we still will keep this bug open till related job pass for whql.
> 
> Thanks for your efforts!
> Best Regards,
> Dawn
Comment 12 dawu 2012-12-06 22:30:44 EST
Reproduce this bug on virtio-win-prewhql-43, verified this bug on virtio-win-prewhql-48 with the same steps in comment #0, also verified this bug on virtio-win-prewhql-48 for related whql job "Crashdump Support Test(LOGO)":

Actually Results:
on version virtio-win-prewhql-43, can reproduce this bug.
on version virtio-win-prewhql-48, dump can generate successfully and pass whql related job "Crashdump Support Test(LOGO)".

Based on above this issue has been fixed.

Thanks!

Best Regards,
Dawn
Comment 13 Mike Cao 2012-12-18 02:19:01 EST
According to comment#12 move status to VERIFIED.
Comment 14 errata-xmlrpc 2013-02-21 05:42:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.