Bug 876446 - Remote-viewer will still create 2 displays even the 2nd monitor has been unplugged.
Remote-viewer will still create 2 displays even the 2nd monitor has been unpl...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-14 02:35 EST by Geyang Kong
Modified: 2013-08-04 23:45 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-09 17:56:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Geyang Kong 2012-11-14 02:35:30 EST
Description of problem:
  Remote-viewer will still create 2 displays even the 2nd monitor has been unplugged.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64
spice-server-0.12.0-2.el6.x86_64
spice-glib-0.14-5.el6.x86_64
spice-gtk-tools-0.14-5.el6.x86_64
spice-gtk-python-0.14-5.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-gtk-0.14-5.el6.x86_64
spice-protocol-0.12.2-1.el6.noarch

How reproducible:
100%

Reproduce steps:
1. Have a notebook computer and plugged another display to its VGA interface.
2. Install a rhel guest on it, make sure it has spice+qxl device and spicevmc channel.
3. Update spice-vdagent and xorg-x11-drv-qxl
4. Run remote-viewer spice://127.0.0.1:5900 --full-screen=auto-conf
5. Quit remote-viewer
6. Unplugged the 2nd monitor
7. Run remote-viewer spice://127.0.0.1:5900 or virt-viewer $guestname

Actual results:
1. After step 7, remote-viewer/virt-viewer still creates 2 displays

Expected results:
1. After step 7, only 1 display will be created

Additional info:
Comment 4 Marc-Andre Lureau 2013-05-09 17:56:56 EDT
What you describe is not a bug.

If the guest is configured with 2 monitors (after full-screen=auto-conf step here), connecting back without auto-conf will open the existing monitors.

Please reopene if I am missing something from your report.
Comment 5 Geyang Kong 2013-05-10 01:15:54 EDT
OK, looks it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.