Bug 876672 - mod_proxy_ajp don't works with mod_usertrack
mod_proxy_ajp don't works with mod_usertrack
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Web Stack Team
BaseOS QE - Apps
: Patch
Depends On:
Blocks: 921048 1049888
  Show dependency treegraph
 
Reported: 2012-11-14 12:16 EST by Eric Rich
Modified: 2014-02-04 10:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-04 10:08:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Rich 2012-11-14 12:16:42 EST
Description of problem:

Cookie generated by mod_usertrack is not added to results proxied from ajp 
sessions. This is bug in ajp proxy, not usertrack module, so i am filling
a new bug report. Sample configuration:

Additional info:
    https://issues.apache.org/bugzilla/show_bug.cgi?id=40571 
        which points to 
    https://issues.apache.org/bugzilla/show_bug.cgi?id=25543#c6
Comment 1 Jan Kaluža 2012-11-15 03:07:54 EST
http://svn.apache.org/viewvc?view=revision&revision=711850

I think this is proper patch for this issue. I'm going to try it on RHEL5 and will write the results here.
Comment 4 Eric Rich 2012-11-29 18:08:45 EST
Would it be possible to get a test patch.
Comment 5 Joe Orton 2012-12-21 04:20:13 EST
There's a patch above, do you mean a test build?
Comment 7 Joe Orton 2013-01-22 06:43:02 EST
Please let us know if you want a test build for this.
Comment 8 RHEL Product and Program Management 2013-05-01 02:44:03 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2014-01-22 11:32:44 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Note You need to log in before you can comment on or make changes to this bug.