Bug 877109 - An Error while trying to install RHEV 3.1 all in one
An Error while trying to install RHEV 3.1 all in one
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Alex Lourie
Meni Yakove
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 12:35 EST by Nir Magnezi
Modified: 2012-12-04 15:00 EST (History)
9 users (show)

See Also:
Fixed In Version: si24.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nir Magnezi 2012-11-15 12:35:54 EST
Description of problem:
=======================
An Error while trying to install RHEV 3.1 all in one

Version-Release number of selected component (if applicable):
=============================================================
RHEVM 3.1
rhevm-setup-plugin-allinone-3.1.0-30.el6ev.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. yum install rhevm
2. engine-setup
3. engine-cleanup 
4. install rhevm all-on-one : yum install -y rhevm-setup-plugin-allinone.noarch
5. engine-setup
  
Actual results:
===============
engine-setup_2012_11_15_16_44_50.log

Error: Timed out while waiting for host to start

Expected results:
=================
No Errors should be expected.

Additional info:
================
1. Log attached to this bug.
2. When I check the webadmin i see the host was added, but i don't see local storage.
Comment 2 Pavel Stehlik 2012-11-16 04:44:43 EST
I've just tried on si24.2 & I succeed. Only what takes quite time was:
...
AIO: Adding Local storage (This may take several minutes)...  [DONE]
...
I think the message is clear enough.

Afterwards I open webadmin, login, switch tab to Storage & see the local_storage.
I created VM & was able to run it.

What comes to my mind: could be an issue with browser cache? I saw reporter installed already engine before.

Nir  is it possible to create a VM there (on the local_storage) ?
Comment 4 Nir Magnezi 2012-11-16 08:54:15 EST
Created attachment 646330 [details]
logs

adding the relevant logs
Comment 7 Alex Lourie 2012-11-18 08:39:02 EST
We would like to be inline with the backend here. So we agree to wait for a long time for this operation to finish.

Fix is uploaded for review: http://gerrit.ovirt.org/#/c/9297/
Comment 8 Meni Yakove 2012-11-18 08:52:41 EST
Tried on SI24.2 and get timeout but in my case rhevm bridge never created and on VDSM log I get SSL errors.

SSLError: [Errno 1] _ssl.c:490: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown
Thread-6060::ERROR::2012-11-18 15:49:30,618::SecureXMLRPCServer::73::root::(handle_error) client ('10.35.102.23', 60417)
Traceback (most recent call last):
  File "/usr/lib64/python2.6/SocketServer.py", line 560, in process_request_thread
    self.finish_request(request, client_address)
  File "/usr/lib64/python2.6/site-packages/vdsm/SecureXMLRPCServer.py", line 66, in finish_request
    request.do_handshake()
  File "/usr/lib64/python2.6/ssl.py", line 279, in do_handshake
    self._sslobj.do_handshake()
Comment 11 Meni Yakove 2012-11-22 10:39:00 EST
Install All in one SI24.4, Install without errors.

Note You need to log in before you can comment on or make changes to this bug.