Bug 877547 - Can't update a bug when it is a duplicate of a bug it blocks
Summary: Can't update a bug when it is a duplicate of a bug it blocks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 4.2
Hardware: Unspecified
OS: Unspecified
high
unspecified vote
Target Milestone: 4.2-7
Assignee: Simon Green
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-16 20:33 UTC by Simon Green
Modified: 2018-12-09 06:29 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-11-20 23:05:42 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 470051 None None None Never

Internal Trackers: 470051

Description Simon Green 2012-11-16 20:33:32 UTC
Description of problem:
If a bug is both a duplicate of and blocks a bug, you get an error when trying to update the bug.

Version-Release number of selected component (if applicable):
4.2.4-6

How reproducible:
always

Steps to Reproduce:
1. Visit bug 175951 (which is a duplicate of and blocks 187810)
2. Make a comment on the bug
  
Actual results:
Error "You can't make a bug block itself or depend on itself."

Expected results:
No error, comment is added.

Additional info:
This was caused by bug 470051, which is trying to copy the blockers to the duplicate bug. You could also possibly cause this error by marking a blocker a duplicate too, or visa versa.

This will be fixed by not copying a blocker to a duplicate if they are the same.

Comment 2 Jin Zhao 2012-11-19 02:32:25 UTC
Should be bugzilla‑4.2‑6 hot fix


Note You need to log in before you can comment on or make changes to this bug.