Bug 877779 - Review Request: openwebbeans - Implementation of the JSR-299 WebBeans
Review Request: openwebbeans - Implementation of the JSR-299 WebBeans
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Radej
Fedora Extras Quality Assurance
:
Depends On: 987465
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-18 13:33 EST by gil cattaneo
Modified: 2013-08-28 18:19 EDT (History)
4 users (show)

See Also:
Fixed In Version: openwebbeans-1.2.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 17:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
tradej: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)
openwebbeans errors with m-p-b in f19 (196.78 KB, text/plain)
2012-11-18 15:56 EST, gil cattaneo
no flags Details

  None (edit)
Description gil cattaneo 2012-11-18 13:33:31 EST
Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.1.6-1.fc16.src.rpm
Description: 
OpenWebBeans is an implementation of the JSR-299, Contexts and
Dependency Injection for the Java EE platform.

It also already incorporates some features which are part of JSR-346
but doesn't need API changes as we still use the JCDI-1.0 API. The
incorporated CDI-1.1 features are mostly parts which are not well defined
in the CDI-1.0 specification, like Serialisation checks, etc.

Fedora Account System Username: gil
Comment 1 gil cattaneo 2012-11-18 15:55:00 EST
tested on: http://koji.fedoraproject.org/koji/taskinfo?taskID=4701652
with f18, in f19 there are some problem with maven-plugin-bundle (see attached file)
Comment 2 gil cattaneo 2012-11-18 15:56:13 EST
Created attachment 647342 [details]
openwebbeans errors with m-p-b in f19
Comment 3 gil cattaneo 2012-11-21 10:55:22 EST
fixed build problems in f19, thanks to A. Grimm
tested on http://koji.fedoraproject.org/koji/taskinfo?taskID=4713148
Comment 4 gil cattaneo 2012-12-21 18:01:07 EST
Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.1.7-1.fc18.src.rpm

- update to 1.1.7
Comment 5 Tomas Radej 2013-05-07 04:39:30 EDT
Hi. Version 1.1.8 is available, while 1.1.7 is no longer present on the server. Please update it and I will do the review.
Comment 6 gil cattaneo 2013-05-07 05:32:18 EDT
Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.1.8-1.fc18.src.rpm

- update to 1.1.8
- disable tomcat6 module

Tested on: http://koji.fedoraproject.org/koji/taskinfo?taskID=5338679
Comment 7 Tomas Radej 2013-05-10 07:46:43 EDT
Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
[!]: Package requires other packages for directories it uses.
[!]: Packages have proper BuildRequires/Requires on jpackage-utils
     See: https://fedoraproject.org/wiki/Packaging:Java
[!]: Javadoc subpackages have Requires: jpackage-utils
     See: https://fedoraproject.org/wiki/Packaging:Java
>>>> Requires on jpackage-utils is necessary

[!]: Fully versioned dependency in subpackages, if present.
     Note: Missing: Requires: %{name} = %{version}-%{release} in openwebbeans-
     arquillian, openwebbeans-ee, openwebbeans-ee-common, openwebbeans-ejb,
     openwebbeans-impl, openwebbeans-jee5-ejb-resource, openwebbeans-jms,
     openwebbeans-jsf, openwebbeans-osgi, openwebbeans-resource, openwebbeans-
     spi, openwebbeans-test, openwebbeans-tomcat7, openwebbeans-web
     See: http://fedoraproject.org/wiki/Packaging/Guidelines#RequiringBasePackage
>>>> The dependency on main package must be in form of:
>>>> Requires: %{name}%{?_isa} = %{version}-%{release}


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[!]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[ ]: Fully versioned dependency in subpackages, if present.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     openwebbeans-arquillian , openwebbeans-ee , openwebbeans-ee-common ,
     openwebbeans-ejb , openwebbeans-impl , openwebbeans-jee5-ejb-resource ,
     openwebbeans-jms , openwebbeans-jsf , openwebbeans-osgi , openwebbeans-
     resource , openwebbeans-spi , openwebbeans-test , openwebbeans-tomcat7 ,
     openwebbeans-web , openwebbeans-javadoc
[ ]: Package complies to the Packaging Guidelines
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Apache (v2.0)". 1 files have unknown license. Detailed output of
     licensecheck in /home/tradej/reviews/877779-openwebbeans/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 307200 bytes in 30 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

Java:
[x]: Javadoc documentation files are generated and included in -javadoc
     subpackage
[x]: Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlink)
[x]: Bundled jar/class files should be removed before build

Maven:
[x]: Pom files have correct add_maven_depmap call
     Note: Some add_maven_depmap calls found. Please check if they are correct
[-]: If package contains pom.xml files install it (including depmaps) even
     when building with ant
[x]: Old add_to_maven_depmap macro is not being used
[x]: Packages DOES NOT have Requires(post) and Requires(postun) on jpackage-
     utils for %update_maven_depmap macro
[x]: Package DOES NOT use %update_maven_depmap in %post/%postun
[x]: Packages use %{_mavenpomdir} instead of %{_datadir}/maven2/poms

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

Java:
[x]: Package has BuildArch: noarch (if possible)
[x]: Package uses upstream build method (ant/maven/etc.)

===== EXTRA items =====

Generic:
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: openwebbeans-1.1.8-1.fc20.noarch.rpm
          openwebbeans-arquillian-1.1.8-1.fc20.noarch.rpm
          openwebbeans-ee-1.1.8-1.fc20.noarch.rpm
          openwebbeans-ee-common-1.1.8-1.fc20.noarch.rpm
          openwebbeans-ejb-1.1.8-1.fc20.noarch.rpm
          openwebbeans-impl-1.1.8-1.fc20.noarch.rpm
          openwebbeans-jee5-ejb-resource-1.1.8-1.fc20.noarch.rpm
          openwebbeans-jms-1.1.8-1.fc20.noarch.rpm
          openwebbeans-jsf-1.1.8-1.fc20.noarch.rpm
          openwebbeans-osgi-1.1.8-1.fc20.noarch.rpm
          openwebbeans-resource-1.1.8-1.fc20.noarch.rpm
          openwebbeans-spi-1.1.8-1.fc20.noarch.rpm
          openwebbeans-test-1.1.8-1.fc20.noarch.rpm
          openwebbeans-tomcat7-1.1.8-1.fc20.noarch.rpm
          openwebbeans-web-1.1.8-1.fc20.noarch.rpm
          openwebbeans-javadoc-1.1.8-1.fc20.noarch.rpm
openwebbeans-tomcat7.noarch: E: explicit-lib-dependency tomcat-lib
16 packages and 0 specfiles checked; 1 errors, 0 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint openwebbeans-javadoc openwebbeans-arquillian openwebbeans-web openwebbeans-jms openwebbeans-impl openwebbeans openwebbeans-tomcat7 openwebbeans-jsf openwebbeans-test openwebbeans-ee-common openwebbeans-spi op 
enwebbeans-ejb openwebbeans-ee openwebbeans-osgi openwebbeans-resource openwebbeans-jee5-ejb-resource
openwebbeans-tomcat7.noarch: E: explicit-lib-dependency tomcat-lib
16 packages and 0 specfiles checked; 1 errors, 0 warnings.
# echo 'rpmlint-done:'



Requires
--------
openwebbeans-javadoc (rpmlib, GLIBC filtered):
    jpackage-utils

openwebbeans-arquillian (rpmlib, GLIBC filtered):
    arquillian-core
    jpackage-utils
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi
    shrinkwrap

openwebbeans-web (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jboss-el-2.2-api
    jboss-interceptors-1.1-api
    jboss-jsf-2.1-api
    jboss-jsp-2.2-api
    jboss-servlet-3.0-api
    jpackage-utils
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi

openwebbeans-jms (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jboss-jms-1.1-api
    jpackage-utils
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi

openwebbeans-impl (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    javassist
    jboss-el-2.2-api
    jboss-interceptors-1.1-api
    jpackage-utils
    objectweb-asm
    openwebbeans
    openwebbeans-spi
    scannotation

openwebbeans (rpmlib, GLIBC filtered):
    java
    jpackage-utils

openwebbeans-tomcat7 (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jpackage-utils
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi
    openwebbeans-web
    tomcat-lib

openwebbeans-jsf (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jboss-el-2.2-api
    jboss-jsf-2.1-api
    jboss-servlet-3.0-api
    jpackage-utils
    junit
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi

openwebbeans-test (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jboss-el-2.2-api
    jboss-interceptors-1.1-api
    jboss-servlet-3.0-api
    jpackage-utils
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi
    openwebbeans-web

openwebbeans-ee-common (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jpackage-utils
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi

openwebbeans-spi (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    geronimo-annotation
    geronimo-jta
    geronimo-validation
    hamcrest12
    jboss-el-2.2-api
    jboss-jsf-2.1-api
    jboss-servlet-3.0-api
    jpackage-utils
    junit
    openwebbeans

openwebbeans-ejb (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jboss-ejb-3.1-api
    jboss-interceptors-1.1-api
    jpackage-utils
    junit
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi

openwebbeans-ee (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    geronimo-jta
    geronimo-validation
    jboss-el-2.2-api
    jboss-jsf-2.1-api
    jboss-servlet-3.0-api
    jpackage-utils
    junit
    openwebbeans
    openwebbeans-ee-common
    openwebbeans-impl
    openwebbeans-spi

openwebbeans-osgi (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    eclipse-equinox-osgi
    jboss-servlet-3.0-api
    jpackage-utils
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi
    xbean

openwebbeans-resource (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    hibernate-jpa-2.0-api
    jpackage-utils
    junit
    openwebbeans
    openwebbeans-impl
    openwebbeans-spi

openwebbeans-jee5-ejb-resource (rpmlib, GLIBC filtered):
    atinject
    cdi-api
    jboss-ejb-3.1-api
    jpackage-utils
    junit
    openwebbeans
    openwebbeans-impl
    openwebbeans-resource
    openwebbeans-spi



Provides
--------
openwebbeans-javadoc:
    openwebbeans-javadoc

openwebbeans-arquillian:
    mvn(org.apache.openwebbeans.arquillian:owb-arquillian-parent)
    mvn(org.apache.openwebbeans.arquillian:owb-arquillian-standalone)
    openwebbeans-arquillian
    osgi(owb-arquillian-standalone)

openwebbeans-web:
    mvn(org.apache.openwebbeans:openwebbeans-web)
    openwebbeans-web
    osgi(openwebbeans-web)

openwebbeans-jms:
    mvn(org.apache.openwebbeans:openwebbeans-jms)
    openwebbeans-jms
    osgi(openwebbeans-jms)

openwebbeans-impl:
    mvn(org.apache.openwebbeans:openwebbeans-impl)
    openwebbeans-impl
    osgi(openwebbeans-impl)

openwebbeans:
    mvn(org.apache.openwebbeans:openwebbeans)
    openwebbeans

openwebbeans-tomcat7:
    mvn(org.apache.openwebbeans:openwebbeans-tomcat7)
    openwebbeans-tomcat7
    osgi(openwebbeans-tomcat7)

openwebbeans-jsf:
    mvn(org.apache.openwebbeans:openwebbeans-jsf)
    openwebbeans-jsf
    osgi(openwebbeans-jsf)

openwebbeans-test:
    mvn(org.apache.openwebbeans.test:cditest)
    mvn(org.apache.openwebbeans.test:cditest-owb)
    mvn(org.apache.openwebbeans.test:parent)
    openwebbeans-test
    osgi(cditest)
    osgi(cditest-owb)
    osgi(openwebbeans-impl)

openwebbeans-ee-common:
    mvn(org.apache.openwebbeans:openwebbeans-ee-common)
    openwebbeans-ee-common
    osgi(openwebbeans-ee-common)

openwebbeans-spi:
    mvn(org.apache.openwebbeans:openwebbeans-spi)
    openwebbeans-spi
    osgi(openwebbeans-spi)

openwebbeans-ejb:
    mvn(org.apache.openwebbeans:openwebbeans-ejb)
    openwebbeans-ejb
    osgi(openwebbeans-ejb)

openwebbeans-ee:
    mvn(org.apache.openwebbeans:openwebbeans-ee)
    openwebbeans-ee
    osgi(openwebbeans-ee)

openwebbeans-osgi:
    mvn(org.apache.openwebbeans:openwebbeans-osgi)
    openwebbeans-osgi
    osgi(openwebbeans-osgi)

openwebbeans-resource:
    mvn(org.apache.openwebbeans:openwebbeans-resource)
    openwebbeans-resource
    osgi(openwebbeans-resource)

openwebbeans-jee5-ejb-resource:
    mvn(org.apache.openwebbeans:openwebbeans-jee5-ejb-resource)
    openwebbeans-jee5-ejb-resource
    osgi(openwebbeans-jee5-ejb-resource)



MD5-sum check
-------------
http://www.apache.org/dist/openwebbeans/1.1.8/openwebbeans-1.1.8-source-release.zip :
  CHECKSUM(SHA256) this package     : 512623e56f197e27a658903ad078358a171a4d0ddae5f6b23e648a6eee36e75b
  CHECKSUM(SHA256) upstream package : 512623e56f197e27a658903ad078358a171a4d0ddae5f6b23e648a6eee36e75b


Generated by fedora-review 0.4.0 (660ce56) last change: 2013-01-29
Buildroot used: fedora-rawhide-x86_64
Command line :/usr/bin/fedora-review -b 877779 -m fedora-rawhide-x86_64

*** NOT APPROVED *** 

Issues described at the top of this post.
Comment 8 Stanislav Ochotnicky 2013-05-10 08:22:39 EDT
(In reply to comment #7)
> Issues:
> =======
> ...
> [!]: Fully versioned dependency in subpackages, if present.
>      Note: Missing: Requires: %{name} = %{version}-%{release} in
> openwebbeans-
>      arquillian, openwebbeans-ee, openwebbeans-ee-common, openwebbeans-ejb,
>      openwebbeans-impl, openwebbeans-jee5-ejb-resource, openwebbeans-jms,
>      openwebbeans-jsf, openwebbeans-osgi, openwebbeans-resource,
> openwebbeans-
>      spi, openwebbeans-test, openwebbeans-tomcat7, openwebbeans-web
>      See:
> http://fedoraproject.org/wiki/Packaging/Guidelines#RequiringBasePackage
> >>>> The dependency on main package must be in form of:
> >>>> Requires: %{name}%{?_isa} = %{version}-%{release}

Incorrect, this is a bug in fedora-review. %{?_isa} doesn't make sense in noarch packages. In normal packages they resolve to either i686 or x86_64 so that subpackages don't accidentally pull in main package from different architecture. This is never going to happen in noarch package ergo %{?_isa} would actually cause problems
Comment 9 gil cattaneo 2013-05-10 10:34:18 EDT
well, so what? i must change
Requires: %{name} = %{version}-%{release}
in
Requires: %{name}%{?_isa} = %{version}-%{release}
?
or there are others problems because the package is not approved?
thanks
Comment 10 Tomas Radej 2013-05-13 07:17:22 EDT
I apologize for the _isa thing, I misread the line in Packaging Guidelines that this is a requirement "for « non-noarch » packages", thinking that it said "noarch packages". 

Only the requirements on jpackage-utils are necessary and you're good to go.
Comment 11 gil cattaneo 2013-05-13 08:03:34 EDT
hi 
references in the spec file for JPackage-utils I've already removed when I upgraded package
Comment 12 gil cattaneo 2013-05-13 16:52:22 EDT
(In reply to comment #10)
> I apologize for the _isa thing, I misread the line in Packaging Guidelines
> that this is a requirement "for « non-noarch » packages", thinking that it
> said "noarch packages". 
> 
> Only the requirements on jpackage-utils are necessary and you're good to go.

until 2013-04-26 there are some changes in the Packaging Guidelines which i dont know?
from a previous review:
"- Javadoc subpackages do not have Requires: jpackage-utils
   Note: jpackage-utils requires are automatically generated by the
  buildsystem

  Point was that there is no need to because RPM will automatically generate that
  requires. Wording of that check in f-r has been fixed now"
regards
Comment 13 gil cattaneo 2013-05-15 01:03:19 EDT
Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.1.8-2.fc18.src.rpm

- added jpackage-utils references
Comment 14 gil cattaneo 2013-05-25 16:46:53 EDT
Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.1.8-2.fc18.src.rpm

replaced
BuildRequires: jboss-ejb-3.1-api
BuildRequires: jboss-interceptors-1.1-api
BuildRequires: jboss-jms-1.1-api

Requires:      jboss-ejb-3.1-api

Requires:      jboss-interceptors-1.1-api

Requires:      jboss-jms-1.1-api

with
BuildRequires: geronimo-ejb
BuildRequires: geronimo-interceptor
BuildRequires: geronimo-jms

Requires:      geronimo-ejb

Requires:      geronimo-interceptor

Requires:      geronimo-jms
Comment 15 gil cattaneo 2013-05-25 17:59:51 EDT
Fix support for cdi-api
see https://issues.apache.org/jira/browse/OWB-802
Comment 16 gil cattaneo 2013-07-11 14:08:04 EDT
Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.1.8-3.fc19.src.rpm

- built with XMvn
- adapt to current guideline
i.e. see https://fedoraproject.org/wiki/Packaging:Java#Apache_Maven_2
Comment 17 gil cattaneo 2013-07-23 08:55:23 EDT
Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.1.8-4.fc19.src.rpm

- used geronimo-jcdi-1.0-api, for avoid conflicts with new cdi-api 1.1
Comment 18 gil cattaneo 2013-07-23 08:56:30 EDT
replaced
BuildRequires: geronimo-interceptor
with
BuildRequires: jboss-interceptors-1.1-api
Comment 19 gil cattaneo 2013-08-09 02:37:34 EDT
what happen?
Comment 20 Tomas Radej 2013-08-15 03:59:32 EDT
I am sorry, as I was very busy in the last months, I completely forgot about this request. I will attend to it ASAP.
Comment 21 Tomas Radej 2013-08-15 04:50:15 EDT
I have approved the review for geronimo-jcdi-1.0-api. Once that package is in Fedora, I can approve this package as well.
Comment 23 Tomas Radej 2013-08-20 05:41:47 EDT
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
[!]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
     Note: Using prebuilt rpms.
>>>> maven-dependency-plugin is missing

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[!]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
     Note: Using prebuilt rpms.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package complies to the Packaging Guidelines
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Apache (v2.0)". Detailed output of licensecheck in
     /home/tradej/development/reviews/openwebbeans/review-
     openwebbeans/licensecheck.txt
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[-]: Large documentation must go in a -doc subpackage.
[x]: Packages must not store files under /srv, /opt or /usr/local
     Note: Cannot unpack rpms (using --prebuilt?)
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
     Note: Re-using old build in mock
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: No rpmlint messages.

Java:
[x]: Packages have proper BuildRequires/Requires on jpackage-utils
     Note: Maven packages do not need to (Build)Require jpackage-utils. It is
     pulled in by maven-local
[x]: Fully versioned dependency in subpackages, if present.
[x]: Bundled jar/class files should be removed before build

Maven:
[-]: If package contains pom.xml files install it (including depmaps) even
     when building with ant
[x]: Maven packages should use new style packaging
[x]: Old add_to_maven_depmap macro is not being used

===== SHOULD items =====

Generic:
[!]: Reviewer should test that the package builds in mock.
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

Java:
[x]: Package uses upstream build method (ant/maven/etc.)
[x]: Packages are noarch unless they use JNI

===== EXTRA items =====

Generic:
[-]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: 
0 packages and 0 specfiles checked; 0 errors, 0 warnings.




Rpmlint (installed packages)
----------------------------
Cannot parse rpmlint output:


Requires
--------


Provides
--------


Source checksums
----------------
http://www.apache.org/dist/openwebbeans/1.2.0/openwebbeans-1.2.0-source-release.zip :
  CHECKSUM(SHA256) this package     : 7c7b859612189edf5b0824b7f41c1fd84d0c64c66d7c26d09f5803b1f1f63647
  CHECKSUM(SHA256) upstream package : 7c7b859612189edf5b0824b7f41c1fd84d0c64c66d7c26d09f5803b1f1f63647


Generated by fedora-review 0.4.1 (b2e211f) last change: 2013-04-29
Buildroot used: fedora-19-x86_64
Command line :/usr/bin/fedora-review -n openwebbeans --no-build


*** APPROVED ***
BuildRequires on maven-dependency-plugin is missing, but after adding it, the package builds fine. Please, add this BR before committing.
Comment 24 gil cattaneo 2013-08-20 07:44:42 EDT
Thanks!

Spec URL: http://gil.fedorapeople.org/openwebbeans.spec
SRPM URL: http://gil.fedorapeople.org/openwebbeans-1.2.0-1.fc19.src.rpm

- add maven-dependency-plugin

New Package SCM Request
=======================
Package Name: openwebbeans
Short Description: Implementation of the JSR-299 WebBeans
Owners: gil
Branches: f19
InitialCC: java-sig
Comment 25 Jon Ciesla 2013-08-20 08:13:57 EDT
Git done (by process-git-requests).
Comment 26 Fedora Update System 2013-08-20 09:40:52 EDT
openwebbeans-1.2.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openwebbeans-1.2.0-1.fc19
Comment 27 Fedora Update System 2013-08-20 20:12:45 EDT
openwebbeans-1.2.0-1.fc19 has been pushed to the Fedora 19 testing repository.
Comment 28 Fedora Update System 2013-08-28 17:31:28 EDT
openwebbeans-1.2.0-1.fc19 has been pushed to the Fedora 19 stable repository.

Note You need to log in before you can comment on or make changes to this bug.