Bug 87796 - Can't play sounds using arts : /usr/lib/libartscbackend.la missing
Can't play sounds using arts : /usr/lib/libartscbackend.la missing
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: arts (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-02 11:53 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-03 10:33:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-04-02 11:53:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
This is a completely new install of Redhat 9. I am using KDE. 
XMMS Output plug-in is set to aRTS driver 0.4 (libartsout.so). I start xmms
click Play and I get

arts_init error: loading the aRts backend "/usr/lib/libartscbackend.la" failed

I looked around the file system and there is no such file :-(.

I also tried running 

artsdsp realplay 

which used to work under 8.0 freezes up when the GUI comes up. I ran 

strace artsdsp realplay 

and I get

open("/usr/lib/libartscbackend.la", O_RDONLY) = -1 ENOENT (No such file or
directory)
close(10)                               = 0
open("/dev/dsp", O_WRONLY <unfinished ...>

It waits forever on the last statement.

Version-Release number of selected component (if applicable):
arts-1.1-7

How reproducible:
Always

Steps to Reproduce:
 

Additional info:
Comment 1 Ngo Than 2003-04-03 10:33:36 EST
it's fixed in KDE 3.1.1, which you can download from ftp.kde.org.

Note You need to log in before you can comment on or make changes to this bug.