Bug 878244 - Lack of keystone#swiftauth middleware breaks gluster-swift
Lack of keystone#swiftauth middleware breaks gluster-swift
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: openstack-keystone (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-19 17:45 EST by Joe Julian
Modified: 2013-06-23 18:13 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-23 18:13:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2012-11-19 17:45:47 EST
Description of problem:
In order to use keystone, glusterfs-swift utilized the keystone#swiftauth middleware. This has been removed from the Folsom release, breaking existing installations.

Version-Release number of selected component (if applicable):
openstack-keystone-2012.2-6
glusterfs-swift-3.3.1-2

Additional info:
I thought we weren't supposed to do major version upgrades in epel if they break apis?
Comment 1 Alan Pevec 2012-11-20 05:58:35 EST
I don't think keystone#swiftauth was ever part of API, pipeline configuration in paste.ini is an internal implementation detail.

That being said, when has entry point keystone#swiftauth actually worked for you?
I don't see it defined even in Essex Keystone 2012.1 and Essex documentation used direct class path, https://fedoraproject.org/wiki/Getting_started_with_OpenStack_on_Fedora_17#Configure_swift_with_keystone
and http://docs.openstack.org/essex/openstack-compute/install/yum/content/installing-and-configuring-the-proxy-node.html
both have:
[filter:keystone]
paste.filter_factory = keystone.middleware.swift_auth:filter_factory

keystone.middleware.swift_auth is still present in Keystone Folsom[1] (should probably be removed in Grizzly) but has been neglected since Swift developers moved it to their repo: https://github.com/openstack/swift/commit/afa4f70024be30cb1a0b84b9744f044f2532904f

[1] http://koji.fedoraproject.org/koji/fileinfo?rpmID=3513107&filename=/usr/lib/python2.6/site-packages/keystone/middleware/swift_auth.py

Note You need to log in before you can comment on or make changes to this bug.