Bug 878560 - maven-shared: Remove/replace (build)requires on plexus-container-default
maven-shared: Remove/replace (build)requires on plexus-container-default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-shared (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 11:59 EST by Stanislav Ochotnicky
Modified: 2016-01-31 20:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 13:09:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stanislav Ochotnicky 2012-11-20 11:59:07 EST
Your package maven-shared either requires or buildrequires plexus-container-default. This package contains old API which is not commonly used and has not contained maven dependency mappings since September 2011. It means that unless your package is using custom dependency map to build, it is not using plexus-container-default. 

In most cases your package is instead using 'plexus-containers-container-default' package. If any pom.xml files contain reference to groupId:artifactId org.codehaus.plexus:plexus-container-default you can replace plexus-container-default with plexus-containers-container-default. If your pom.xml files don't reference mentioned groupId:artifactId it should be safe to remove completely
Comment 1 Jaromír Cápík 2012-11-22 13:09:59 EST
Fixed in rawhide ...

Note You need to log in before you can comment on or make changes to this bug.