Bug 878665 - [abrt] Zim-0.57-2.fc16: socket.py:224:meth:error: [Errno 2] No such file or directory
[abrt] Zim-0.57-2.fc16: socket.py:224:meth:error: [Errno 2] No such file or d...
Status: CLOSED DUPLICATE of bug 885262
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:24297ed8d5fb28326950878945e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-20 16:49 EST by David Kovalsky
Modified: 2014-03-31 19:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 01:04:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-11-20 16:49:54 EST
libreport version: 2.0.10
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/zim
comment:        Started Zim and chose to upgrade notebook
executable:     /usr/bin/zim
kernel:         3.6.6-1.fc16.x86_64
time:           Tue 20 Nov 2012 10:47:26 PM CET
uid:            10625
username:       dkovalsk

backtrace:
:socket.py:224:meth:error: [Errno 2] No such file or directory
:
:Traceback (most recent call last):
:  File "/usr/bin/zim", line 73, in <module>
:    zim.main(argv)
:  File "/usr/lib/python2.7/site-packages/zim/__init__.py", line 445, in main
:    gui = server.get_notebook(notebook)
:  File "/usr/lib/python2.7/site-packages/zim/ipc.py", line 753, in get_notebook
:    return self.get_proxy(RemoteObject(self._notebookklass, uri), open)
:  File "/usr/lib/python2.7/site-packages/zim/ipc.py", line 734, in get_proxy
:    if not self.has_object(remoteobject):
:  File "/usr/lib/python2.7/site-packages/zim/ipc.py", line 699, in call
:    conn = Client(SERVER_ADDRESS, SERVER_ADDRESS_FAMILY)
:  File "/usr/lib64/python2.7/multiprocessing/connection.py", line 169, in Client
:    c = SocketClient(address)
:  File "/usr/lib64/python2.7/multiprocessing/connection.py", line 293, in SocketClient
:    s.connect(address)
:  File "/usr/lib64/python2.7/socket.py", line 224, in meth
:    return getattr(self._sock,name)(*args)
:error: [Errno 2] No such file or directory
:
:Local variables in innermost frame:
:self: <socket._socketobject object at 0x119f1a0>
:args: ('/tmp/zim-dkovalsk/zim-server-socket',)
:name: 'connect'
Comment 1 Robin Lee 2012-11-20 20:17:31 EST
How to reproduce this issue?
Comment 2 David Kovalsky 2012-11-21 05:28:39 EST
Hmm, I think the key here will be having access to my files. 


I'll try making a backup of my notebook and try to get to the problematic file that may be causing this.
Comment 3 Robin Lee 2012-12-10 01:04:22 EST

*** This bug has been marked as a duplicate of bug 885262 ***

Note You need to log in before you can comment on or make changes to this bug.