Bug 87867 - ftp installs fail with: "Unable to read header list"
ftp installs fail with: "Unable to read header list"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 09:14 EST by Pekka Savola
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:56:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update to test (4.97 KB, text/plain)
2003-04-04 13:11 EST, Michael Fulbright
no flags Details
new comps.py to try (36.95 KB, text/plain)
2003-04-07 11:37 EDT, Michael Fulbright
no flags Details

  None (edit)
Description Pekka Savola 2003-04-03 09:14:25 EST
I'm having serious issues with FTP install of (modified -- a few packages
added) RHL9; I also tested with "stock" hdlist and hdlist2 images.

Initial config looks fine, stuff is loaded off the FTP site, but when 
"reading package list" (or the like), I get:

"Unable to read header list.  This may be due to a missing file or bad 
media. Press <return> to try again."

In the console, I see about the following message five times:

readHeaders(): exception content-length getting content-length
File ftp://site/pub/redhat-9/RedHat/base/hdlist not found

.. but hdlist does exists (regenerated many times w/ genhdlist from
anaconda-runtime-9), and tcpdump on the server shows some data (about 70K
only, though!)  is transferred.

I'm using bootdisk.img + drvnet.img; CD-ROM booting was also tested.

The FTP server is "pureftpd" and the network card used is 3c59x 10/100 in
10baseT mode (through a hub)
Comment 1 M Jang 2003-04-03 09:36:20 EST
I get the same message when I try an FTP installation from source files on a MS 
XP Pro FTP server. I've tried it in the same ways (bootdisk and drvnet disks, as 
well as install CD 1 with the linux askmethod command)




FTP installs work fine when I use source files on vsFTP on RHL8.




If FTP installs are limited to specific types of servers, I think Red Hat needs 
to define it in the documentation.
Comment 2 Pekka Savola 2003-04-04 01:35:08 EST
I switched temporarily to vsftpd, and it started working immediately.

I assume there is some subtle bug in the anaconda ftp client code, surfaced at
the rewrite..
Comment 3 Michael Fulbright 2003-04-04 13:11:06 EST
Created attachment 90902 [details]
Update to test

Updated urlinstall.py without content-length checking
Comment 4 Michael Fulbright 2003-04-04 13:12:04 EST
Put this attachment on an ext2 floppy and boot with 'linux updates' and let me
know if it works.
Comment 5 Pekka Savola 2003-04-05 02:09:59 EST
Now I get an eternal loop of:
  
Error occurred getting ftp://fooo/.../RedHat/base/comps.xml
  
FTP server logs show that the hdlist was transferred successfully, though.
Comment 6 Michael Fulbright 2003-04-07 11:37:13 EDT
Created attachment 90959 [details]
new comps.py to try

Please try this on an updates disk in addition to the previous update file.
Comment 7 Pekka Savola 2003-04-08 01:18:56 EDT
This works.
Comment 8 Michael Fulbright 2003-04-08 12:35:49 EDT
Thanks for testing these patches. I will commit to anaconda cvs.
Comment 9 Pekka Savola 2003-04-08 12:49:06 EDT
It would be interesting to see this as errata, too.
Comment 10 M Jang 2003-04-23 12:48:45 EDT
The updates disk work, thank you. Alternatively, the revised anaconda packages 
dated Apr21 (from rawhide) also work for me when using a FTP install from a 
WinXP FTP server.




I realize it isn't possible at this point to update the ISOs, the files in the 
Shrike RPM directory, or the Shrike disk images.




Can you put out a message to RHN users - or at least update this bugzilla (or 
errata as suggested) with the alternative workarounds? (update disk or updated 
anaconda RPMs)
Comment 11 Brent Fox 2003-05-25 10:56:28 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.
Comment 12 Ronny T. Lampert 2003-06-03 10:14:42 EDT
Where are the new images that function? Not in update nor in rawhide
(ftp.redhat.com/....) I found them.
I don't have the possibility to patch the install-discs.
Comment 13 Markus M 2004-02-18 09:17:59 EST
i have exactly the same problem as mentioned above... where are the 
working files (initrd & kernel) ?? I'm using for installation a 
KNOPPIX 3.3 with ftp server (because i'm running it all on the same 
machine using x3270)... By the way how can you display error messages 
while you are in the Loader?

thanks... please help!

Note You need to log in before you can comment on or make changes to this bug.