This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 878743 - An exception was shown when upgrade rhev-h via usb boot media menu
An exception was shown when upgrade rhev-h via usb boot media menu
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 878928
  Show dependency treegraph
 
Reported: 2012-11-21 01:00 EST by haiyang,dong
Modified: 2013-02-28 11:45 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-10.el6
Doc Type: Bug Fix
Doc Text:
Previously, when attempting to install rhev-hypervisor6-6.3-20121112.0.el6_3 using USB boot media, the install would fail. This has been corrected so that installing from USB boot media succeeds.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:45:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot for an exception about upgrade (55.37 KB, image/jpeg)
2012-11-21 01:00 EST, haiyang,dong
no flags Details
attached the ovirt.log (512.75 KB, text/x-log)
2012-11-21 01:04 EST, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-11-21 01:00:46 EST
Created attachment 649057 [details]
Screenshot for an exception about upgrade

Description of problem:
Installed old rhev-hypervisor to local disk, then using command "rhevh-iso-to-disk --format --reset-mbr" to make usb boot media , 
insert the boot media(USB) into machine, and start the system, When the automatic boot prompt appears, press Enter.
and Select the "Install or Upgrade" option, and press Enter.
An exception was shown with error "no such file or directory /live/isolinux/version" during upgrade process(Seen exception about upgrade.jpg )

no this issue when upgrade rhev-h via pxe and cdrom

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20121120.0.el6_3
rhev-hypervisor6-6.3-20121112.0.el6_3

How reproducible:
100% 

Steps to Reproduce:
1. Have installed old rhev-hypervisor to local disk
2. Using usb to make boot media
3. Insert the boot media(USB) into machine, and start the system, When the automatic boot prompt appears, press Enter
4. Select the "Install or Upgrade" option, and press Enter.
5. Enter the correct old password and the new password to continue upgrade,

Actual results:
After step 5,An exception was shown with error "no such file or directory /live/isolinux/version"

Expected results:
upgrade rhev-h success from usb boot media via ovirt-node menu

Additional info:
------
Comment 1 haiyang,dong 2012-11-21 01:04:27 EST
Created attachment 649060 [details]
attached the ovirt.log
Comment 3 haiyang,dong 2012-11-21 04:27:33 EST
No upgrade rhev-h failed via usb boot media menu issue on normal 6.3.z build(rhev-hypervisor6-6.3-20121025.0.el6_3), so marked it a regression bug.
Comment 11 haiyang,dong 2013-01-21 05:32:31 EST

Test version:
rhev-hypervisor6-6.4-20130116.3.0.el6
ovirt-node-2.5.0-15.el6.noarch

Steps to Reproduce:
1. Have installed rhev-hypervisor6-6.4-20130116.3.0.el6 to local disk
2. Using usb to make boot media
3. Insert the boot media(USB) into machine, and start the system, When the automatic boot prompt appears, press Enter
4. Select the "Install or Upgrade" option, and press Enter.
5. Enter the correct old password and the new password to continue upgrade,

upgrade rhev-h success from usb boot media via ovirt-node menu.
So change the status into “VERIFIED”
Comment 13 errata-xmlrpc 2013-02-28 11:45:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.