Bug 878925 - [RFE] [TEXT] please distinguish between wrong master domain or its version error message
[RFE] [TEXT] please distinguish between wrong master domain or its version er...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Maor
Haim
storage
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 09:52 EST by Haim
Modified: 2016-02-10 15:24 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 10:40:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
vdsm log (5.82 MB, application/x-bzip)
2012-11-21 09:54 EST, Haim
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21175 None None None Never

  None (edit)
Description Haim 2012-11-21 09:52:03 EST
Description of problem:

1) connect host to storage pool
2) might get the following error message:


Thread-78::ERROR::2012-11-20 22:26:32,819::task::853::TaskManager.Task::(_setError) Task=`bcbf77f1-1382-4483-96f9-4390624f31ad`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 861, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 38, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 862, in connectStoragePool
    return self._connectStoragePool(spUUID, hostID, scsiKey, msdUUID, masterVersion, options)
  File "/usr/share/vdsm/storage/hsm.py", line 904, in _connectStoragePool
    res = pool.connect(hostID, scsiKey, msdUUID, masterVersion)
  File "/usr/share/vdsm/storage/sp.py", line 648, in connect
    self.__rebuild(msdUUID=msdUUID, masterVersion=masterVersion)
  File "/usr/share/vdsm/storage/sp.py", line 1178, in __rebuild
    self.masterDomain = self.getMasterDomain(msdUUID=msdUUID, masterVersion=masterVersion)
  File "/usr/share/vdsm/storage/sp.py", line 1526, in getMasterDomain
    raise se.StoragePoolWrongMaster(self.spUUID, msdUUID)
StoragePoolWrongMaster: Wrong Master domain or its version: 'SD=25a0b810-c6a9-48cc-9f11-9ed816c7648a, pool=96d1b5db-4798-4284-b355-822980dc120d'
Thread-78::DEBUG::2012-11-20 22:26:32,822::task::872::TaskManager.Task::(_run) Task=`bcbf77f1-1382-4483-96f9-4390624f31ad`::Task._run: bcbf77f1-1382-4483-96f9-4390624f31ad ('96d1b5db-4798-4284-b355-822980dc120d', 1, '96d1b5db-4798-4284-b355-822980dc120d', '25a0b810-c6a9-48cc-9f11-9ed816c7648a', 1) {} failed - stopping task
Thread-78::DEBUG::2012-11-20 22:26:32,822::task::1199::TaskManager.Task::(stop) Task=`bcbf77f1-1382-4483-96f9-4390624f31ad`::stopping in state preparing (force False)


expected results:

1) please distinguish between wrong master passed or wrong master version and prompt error accordingly.
Comment 1 Haim 2012-11-21 09:54:19 EST
Created attachment 649272 [details]
vdsm log
Comment 4 Haim 2013-12-16 05:12:33 EST
I suggest to close this bug, its not really intersting.
Comment 5 Maor 2013-12-16 10:40:14 EST
Based on Haim comment, and also since the pool is about to be removed in 3.4, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.