Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 879099 - Project-wide search does not show results for matching substring
Summary: Project-wide search does not show results for matching substring
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 2.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 2.0
Assignee: David Mason
QA Contact: Patrick Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-22 03:43 UTC by Hedda Peters
Modified: 2013-02-26 03:46 UTC (History)
4 users (show)

Fixed In Version: 2.0.3-SNAPSHOT (20121119-0019)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 03:46:23 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 877242 0 high CLOSED Some characters can't be searched for in "project-wide search and replace" 2021-02-22 00:41:40 UTC

Internal Links: 877242

Description Hedda Peters 2012-11-22 03:43:24 UTC
Description of problem:
The project-wide search does not show results for search terms, if these are a substring of a longer word.

How reproducible:
always

Steps to Reproduce:
1. Open project-wide search
2. Search for the term "exampl" 

Actual results:
Messages containing the word "example" will not be shown in search results

Expected results:
Messages containing the word "example" should be shown in search results

Additional info:
The simple search within a document behaves as expected.
It is important to have the expected behaviour: to be able to find words using a substring, because in some languages words can have all sorts of different endings due to conjugation/declination.

Comment 1 David Mason 2012-11-23 08:40:42 UTC
This should be fixed in 2.0.3-SNAPSHOT and 2.1-SNAPSHOT by the change to HQL query

See: https://github.com/zanata/zanata/commit/1a6d8aae03c2e8856d3864e628320caba1aab64b

Comment 3 Patrick Huang 2012-11-27 02:22:00 UTC
verified in Zanata version 2.1-SNAPSHOT (20121119-1207)

Comment 4 Sean Flanigan 2012-11-27 02:48:16 UTC
But what about 2.0.x?  The target release is 2.0.

Comment 5 Patrick Huang 2012-11-27 02:59:01 UTC
verified in Zanata version 2.0.3-SNAPSHOT (20121119-0019)


Note You need to log in before you can comment on or make changes to this bug.