Bug 879412 - Logging doesn't work
Summary: Logging doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: PressGang CCMS
Classification: Community
Component: REST-API
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: pressgang-ccms-dev
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-22 22:07 UTC by Lee Newson
Modified: 2013-07-01 23:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-01 23:35:45 UTC


Attachments (Terms of Use)

Description Lee Newson 2012-11-22 22:07:55 UTC
When trying to set the logging details outside of the RESTEasy Proxy API, the log details fail to be set.

This initially looks to be caused by the fact that RESTEasy appears to choose the method defined without any query parameters. As such only null is passed for each query parameter.

Comment 1 Lee Newson 2012-11-23 03:54:52 UTC
Fixed in 20121123-1253.

Cause:

The RESTEasy Implementation we were using was shared between the client and server, so there were methods to endpoints without mandatory query parameters. As such when you weren't using the proxy, it would delegate it to the implementation without the query parameters. This then caused any query parameters to be discarded.

Consequence:

Logging and other methods wouldn't work when you are using the framework.

Fix:

Separate the methods into a separate interface that extends the primary methods. That way only the core needs to be implemented on the server and the others in the extended implementation can be used by the client.


Note You need to log in before you can comment on or make changes to this bug.