Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 879641 - core dump uploading broken under cs_CZ locale
Summary: core dump uploading broken under cs_CZ locale
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 880201 880230
TreeView+ depends on / blocked
 
Reported: 2012-11-23 14:36 UTC by Kamil Páral
Modified: 2016-12-01 00:42 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 880201 880230 (view as bug list)
Environment:
Last Closed: 2013-02-26 02:40:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2012-11-23 14:36:17 UTC
Description of problem:
ABRT asked me whether to upload the core dump. I said *YES*. But it started to download debuginfo locally. Why?


--- Running report_uReport ---
(exited with 0)

--- Running analyze_CCpp ---
Ok to upload core dump? (It may contain sensitive data). If your answer is 'No', a stack trace will be generated locally. (It may download a huge amount of data). 'YES'
Analyzing coredump 'coredump'
Coredump references 173 debuginfo files, 173 of them are not installed
Setting up yum repositories
Looking for needed packages in repositories
Packages to download: 94
Downloading (1 of 94) libXtst-debuginfo-1.2.0-3.fc17.x86_64.rpm: 100%
Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-11-23-15:32:23.2199/libXtst-debuginfo-1.2.0-3.fc17.x86_64.rpm
Caching files from unpacked.cpio made from libXtst-debuginfo-1.2.0-3.fc17.x86_64.rpm
Downloading (2 of 94) libtdb-debuginfo-1.2.10-15.fc17.x86_64.rpm: 100%
Extracting cpio from /tmp/abrt-tmp-debuginfo-2012-11-23-15:32:23.2199/libtdb-debuginfo-1.2.10-15.fc17.x86_64.rpm
Caching files from unpacked.cpio made from libtdb-debuginfo-1.2.10-15.fc17.x86_64.rpm
...

I killed the process here. It seems to be reproducible.


Version-Release number of selected component (if applicable):
abrt-2.0.19-1.fc17.x86_64
abrt-addon-ccpp-2.0.19-1.fc17.x86_64
abrt-addon-kerneloops-2.0.19-1.fc17.x86_64
abrt-addon-python-2.0.19-1.fc17.x86_64
abrt-addon-vmcore-2.0.19-1.fc17.x86_64
abrt-addon-xorg-2.0.19-1.fc17.x86_64
abrt-dbus-2.0.19-1.fc17.x86_64
abrt-desktop-2.0.19-1.fc17.x86_64
abrt-gui-2.0.19-1.fc17.x86_64
abrt-libs-2.0.19-1.fc17.x86_64
abrt-plugin-bodhi-2.0.19-1.fc17.x86_64
abrt-retrace-client-2.0.19-1.fc17.x86_64

Comment 1 Kamil Páral 2012-11-23 14:41:03 UTC
There is a minor glitch in the UI, "Yes" button should be on the right side, and "No" should be on the left side, to conform to GNOME interface guidelines. But as you can see from the log, I hit the correct button.

Comment 2 Jakub Filak 2012-11-23 15:14:48 UTC
This bug is probably caused by inconsistency of abrt/libreport translations. I can't reproduce it with english localization.

Comment 3 Kamil Páral 2012-11-23 15:18:38 UTC
No matter what I respond, whether YES or NO (the text log mirrors what I clicked in GUI), it always downloads the packages. What log file do you want?

Comment 4 Kamil Páral 2012-11-23 15:32:16 UTC
I can confirm this works well if I set LC_ALL=en_US.UTF-8. With cs_CZ it behaves as described.

Comment 5 Jakub Filak 2012-11-23 18:01:35 UTC
Fixed in git

commit 6136beb5c669c8c6336b9d6c24a3f60d7528cf6e
Author: Jakub Filak <jfilak@redhat.com>
Date:   Fri Nov 23 17:51:22 2012 +0100

    update translations
    
    - closes rhbz#879641
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>

Comment 6 Fedora Update System 2012-11-26 18:06:03 UTC
btparser-0.23-1.fc17, abrt-2.0.19-2.fc17, libreport-2.0.19-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-18329/abrt-2.0.19-2.fc17,libreport-2.0.19-2.fc17,btparser-0.23-1.fc17

Comment 7 Fedora Update System 2012-11-28 11:27:41 UTC
Package btparser-0.23-1.fc17, abrt-2.0.19-2.fc17, libreport-2.0.19-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing btparser-0.23-1.fc17 abrt-2.0.19-2.fc17 libreport-2.0.19-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18329/abrt-2.0.19-2.fc17,libreport-2.0.19-2.fc17,btparser-0.23-1.fc17
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-12-04 04:55:16 UTC
Package btparser-0.23-1.fc17, abrt-2.0.19-2.fc17, libreport-2.0.19-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing btparser-0.23-1.fc17 abrt-2.0.19-2.fc17 libreport-2.0.19-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18329/abrt-2.0.19-2.fc17,libreport-2.0.19-3.fc17,btparser-0.23-1.fc17
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2012-12-20 09:48:48 UTC
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.20-1.fc17,btparser-0.24-1.fc17,libreport-2.0.20-1.fc17

Comment 10 Fedora Update System 2013-02-26 02:40:21 UTC
abrt-2.0.20-1.fc17, btparser-0.24-1.fc17, libreport-2.0.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.