Bug 879667 - AttributeError: VolumeGroupEditor instance has no attribute 'reservedSpaceLabel'
AttributeError: VolumeGroupEditor instance has no attribute 'reservedSpaceLabel'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: beta
: ---
Assigned To: Brian Lane
Release Test Team
abrt_hash:52d05d04dafa7f7f4f50c8d46fa...
: Regression
Depends On:
Blocks: 841211 881827
  Show dependency treegraph
 
Reported: 2012-11-23 11:03 EST by Ľuboš Kardoš
Modified: 2016-07-31 21:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.21.186-1
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: release (24 bytes, text/plain)
2012-11-23 11:03 EST, Ľuboš Kardoš
no flags Details
File: version (3 bytes, text/plain)
2012-11-23 11:03 EST, Ľuboš Kardoš
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-23 11:03 EST, Ľuboš Kardoš
no flags Details
File: type (9 bytes, text/plain)
2012-11-23 11:03 EST, Ľuboš Kardoš
no flags Details
File: exnFileName (23 bytes, text/plain)
2012-11-23 11:03 EST, Ľuboš Kardoš
no flags Details
File: product (24 bytes, text/plain)
2012-11-23 11:04 EST, Ľuboš Kardoš
no flags Details
File: anaconda-tb-3D92Ax (246.19 KB, text/plain)
2012-11-23 11:04 EST, Ľuboš Kardoš
no flags Details
File: environ (1019 bytes, text/plain)
2012-11-23 11:04 EST, Ľuboš Kardoš
no flags Details
possible fix (12.96 KB, application/octet-stream)
2012-11-26 10:16 EST, Brian Lane
no flags Details

  None (edit)
Description Ľuboš Kardoš 2012-11-23 11:03:48 EST
Version-Release number of selected component:
anaconda-13.21.185

Additional info:
libreport version: 2.0.9
cmdline:        /usr/bin/python  /usr/bin/anaconda
kernel:         2.6.32-343.el6.i686

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.185 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 975, in updateVGSpaceLabels
:    self.reservedSpaceLabel.set_text("%10.2f MB" % reserved)
:  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 1539, in __init__
:    self.updateVGSpaceLabels()
:  File "/usr/lib/anaconda/iw/partition_gui.py", line 1754, in editLVMVolumeGroup
:    device, isNew)
:  File "/usr/lib/anaconda/iw/partition_gui.py", line 1555, in createCB
:    self.editLVMVolumeGroup(tempvg, isNew = True)
:  File "/usr/lib/anaconda/iw/partition_gui.py", line 1576, in _createCB
:    self.createCB(*args)
:AttributeError: VolumeGroupEditor instance has no attribute 'reservedSpaceLabel'
Comment 1 Ľuboš Kardoš 2012-11-23 11:03:51 EST
Created attachment 650534 [details]
File: release
Comment 2 Ľuboš Kardoš 2012-11-23 11:03:53 EST
Created attachment 650535 [details]
File: version
Comment 3 Ľuboš Kardoš 2012-11-23 11:03:55 EST
Created attachment 650536 [details]
File: hashmarkername
Comment 4 Ľuboš Kardoš 2012-11-23 11:03:57 EST
Created attachment 650537 [details]
File: type
Comment 5 Ľuboš Kardoš 2012-11-23 11:03:59 EST
Created attachment 650538 [details]
File: exnFileName
Comment 6 Ľuboš Kardoš 2012-11-23 11:04:01 EST
Created attachment 650539 [details]
File: product
Comment 7 Ľuboš Kardoš 2012-11-23 11:04:03 EST
Created attachment 650540 [details]
File: anaconda-tb-3D92Ax
Comment 8 Ľuboš Kardoš 2012-11-23 11:04:06 EST
Created attachment 650541 [details]
File: environ
Comment 9 Ľuboš Kardoš 2012-11-23 11:09:11 EST
Steps to reproduce:
1. Start installation and proceed to the custom partitioning screen.
2. Create LVM Physical Volume.
3. Try to create LVM Volume Group.

After these steps traceback is showed.
Comment 12 Brian Lane 2012-11-26 10:16:31 EST
Created attachment 652002 [details]
possible fix

Please give this updates image a try.
Comment 13 Ľuboš Kardoš 2012-11-26 10:41:20 EST
I retested it with given updates image and I was able to create LVM volume group and successfully finish the installation.
Comment 14 Marian Ganisin 2012-11-26 10:58:24 EST
My testing also confirms that updates img seems to include bugfix, issue doesn't occur with that
Comment 18 errata-xmlrpc 2013-02-21 05:01:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0373.html

Note You need to log in before you can comment on or make changes to this bug.