This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 879967 - [rhevm-upgrade] rhevm-upgrade fails as /etc/rhevm already exists: error: unpacking of archive failed on file /etc/rhevm: cpio: rename failed - Is a directory
[rhevm-upgrade] rhevm-upgrade fails as /etc/rhevm already exists: error: unpa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Moran Goldboim
Leonid Natapov
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-25 13:10 EST by Haim
Modified: 2014-01-12 19:55 EST (History)
9 users (show)

See Also:
Fixed In Version: si24.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-23 06:31:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
upgrade log. (44.84 KB, application/x-gzip)
2012-11-25 13:12 EST, Haim
no flags Details

  None (edit)
Description Haim 2012-11-25 13:10:34 EST
Description of problem:

rhevm-upgrade failed on the following trying to install ovirt-engine:


012-11-25 17:20:50::DEBUG::common_utils::342::root:: retcode = 0
2012-11-25 17:20:50::DEBUG::upgrade_utils30::210::root:: Yum install started
2012-11-25 17:20:50::DEBUG::common_utils::302::root:: Executing command --> '/usr/bin/yum install -q -y rhevm rhevm-backend rhevm-config rhevm-dbscripts rhevm-genericapi rhevm-notification-service rhevm-restapi rh
evm-setup rhevm-tools-common rhevm-userportal rhevm-webadmin-portal rhevm-image-uploader rhevm-iso-uploader rhevm-log-collector vdsm-bootstrap'
2012-11-25 17:59:53::DEBUG::common_utils::340::root:: output = Package vdsm-bootstrap-4.9.6-44.0.el6_3.noarch already installed and latest version
error: unpacking of archive failed on file /etc/rhevm: cpio: rename failed - Is a directory

2012-11-25 17:59:53::DEBUG::common_utils::341::root:: stderr = Unable to read consumer identity
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
Error unpacking rpm package rhevm-3.1.0-31.el6ev.noarch

2012-11-25 17:59:53::DEBUG::common_utils::342::root:: retcode = 1
2012-11-25 17:59:53::ERROR::upgrade_utils30::214::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine/scripts/upgrade_utils30.py", line 212, in upgrade
    utils.execCmd(cmdList=cmd, failOnError=True, msg="Error: Yum update failed")
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 345, in execCmd
    raise Exception(msg)
Exception: Error: Yum update failed

problem is /etc/rhevm existed and yum failed the unpack new rhevm package since its trying to unpack /etc/rhevm as well.
Comment 1 Haim 2012-11-25 13:12:59 EST
Created attachment 651594 [details]
upgrade log.
Comment 5 Leonid Natapov 2012-12-13 11:08:06 EST
si25. we did several upgrades with si25. problem doesn't reproduced

Note You need to log in before you can comment on or make changes to this bug.