This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 880132 - spec cleanup for recent packaging guidelines
spec cleanup for recent packaging guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 05:38 EST by Parag Nemade
Modified: 2012-11-27 19:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 19:50:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spec cleanup for recent packaging guidelines (4.09 KB, patch)
2012-11-26 05:38 EST, Parag Nemade
no flags Details | Diff

  None (edit)
Description Parag Nemade 2012-11-26 05:38:20 EST
Created attachment 651880 [details]
spec cleanup for recent packaging guidelines

Description of problem:
I have attached my suggested changes in patch. Following are the guidelines I used
1) https://fedoraproject.org/wiki/Packaging:Guidelines#.25global_preferred_over_.25define

2) http://fedoraproject.org/wiki/Packaging:Python#BuildRequires
Changed BR: python to python2-devel

3) Removed python sitelib %define. See http://fedoraproject.org/wiki/Packaging:Python#Macros

4) Updated scriptlets. The notable change is for gtk2 subpackage as given at http://fedoraproject.org/wiki/Packaging:ScriptletSnippets#GTK.2B_modules

5) Can it be possible to fix following issue? Else leave this
[!]: SourceX / PatchY prefixed with %{name}.
     Note: Source1 (xinput-ibus)

6) you can add comment in spec for following issue
ibus.x86_64: W: obsolete-not-provided ibus-gnome3

7) can following lines be removed from spec file?
# Added for F14: need to keep bumping for backports
Obsoletes:  ibus-gtk < %{version}-%{release}
Provides:   ibus-gtk = %{version}-%{release}

Another thing is to ask upstream to correct the fsf address in license headers.

Version-Release number of selected component (if applicable):
ibus-libs-1.4.99.20121109-2.fc18.x86_64.rpm

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 fujiwara 2012-11-27 02:39:41 EST
I updated the build.
https://brewweb.devel.redhat.com/taskinfo?taskID=5130140

(In reply to comment #0)
> Created attachment 651880 [details]
> spec cleanup for recent packaging guidelines
> 
> Description of problem:
> I have attached my suggested changes in patch. Following are the guidelines
> I used

OK, looks good.

> 2) http://fedoraproject.org/wiki/Packaging:Python#BuildRequires
> Changed BR: python to python2-devel

I think if python2-devel is used, python2_sitelib is better.

-%dir %{python_sitelib}/ibus
-%{python_sitelib}/ibus/*
+%dir %{python2_sitelib}/ibus
+%{python2_sitelib}/ibus/*

> 4) Updated scriptlets. The notable change is for gtk2 subpackage as given at
> http://fedoraproject.org/wiki/Packaging:ScriptletSnippets#GTK.2B_modules

This suggests gtk-query-immodules-3.0 only because 
gtk-query-immodules-2.0 does not have --update-cache option.
I also updated the comment line slightly.

Note You need to log in before you can comment on or make changes to this bug.