Bug 88021 - SMB printer configuration issue in redhat-config-printer
SMB printer configuration issue in redhat-config-printer
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2003-04-04 13:56 EST by Matthew Lenz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-07-07 12:36:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
left: redhat 9, right: redhat 8 printer config (149.99 KB, image/png)
2003-04-04 14:05 EST, Matthew Lenz
no flags Details
/usr/share/printconf/util/addQueue.py (42.22 KB, text/plain)
2003-04-07 09:33 EDT, Tim Waugh
no flags Details
/usr/share/printconf/util/backend.py (24.32 KB, text/plain)
2003-04-07 09:34 EDT, Tim Waugh
no flags Details

  None (edit)
Description Matthew Lenz 2003-04-04 13:56:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Redhat 9 printer configuration does not seem to function when attempting to use
the same input values from Redhat 8 (Share, User, Password, Workgroup, IP (I've
always left IP blank).

Redhat 8 was configured like this:

Share: \\jason\hpoffice
User: ourcompanydomain\myusername
Host IP: <blank>
Password: <mypasswordforthedomain>
Workgroup: ourcompanydomain

This printer is a scanner/fax/printer and is connected directly to a windows
machine that is on 'ourcompanydomain'.

I've tried to apply these same settings to Redhat 9 in the following way (by
clicking Specify and filling in the following values in the 'Authentication' window:

Workgroup: ourcompanydomain
Server: <blank>
Share: \\jason\\hpoffice
User name: ourcompanydomaon\myusername
Password: <mypasswordforthedomain>

When I click 'OK' in the 'Authentication' disappears for a bit (like its going
to work) and then comes back with the same data in the fields.  I guess I was
expecting some kind of error message if there is something that isn't correct.

I can only guess that something has changed between 8 and 9 with regards to what
the input fields mean.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. click Print Manager icon in panel
2. Print Manager says there are no printers configured and asks to run the print
configuration tool.  Click OK.
3. Enter root password if needed.
4. Click New, Click Forward, Name: HPoffice, Description: ignore, click Forward.
5. Select Windows SMB as queue type
6. Click Specify
7. Enter values described in Summary, click OK.

Actual Results:  Authentication window goes away and comes back with no
additional feed back.  Continued 'OK' clicks have same result.

Expected Results:  An error message saying something was incorrect.  In this
case it should have worked, all the input fields received the same treatment as
Redhat 8 for the exact same environment and printers.

Additional info:

I'm not exactly sure which component the printer configuration wizard belongs to
but I think its the one I provided (redhat-config-printer)
Comment 1 Matthew Lenz 2003-04-04 14:05:16 EST
Created attachment 90907 [details]
left: redhat 9, right: redhat 8 printer config

Thought this might be useful.
Comment 2 Matthew Lenz 2003-04-04 14:06:04 EST
fixed typo in Summary.
Comment 3 Tim Waugh 2003-04-07 05:53:26 EDT
Thanks for the report.  Okay, I can see several places where this might be going
wrong.  First of all, could you let me know if this works:

/usr/bin/smbclient //jason/HPOffice [yourpassword] -W metroexpressinc -N -P -c
quit -U metroexpressinc/jonc

It should give no errors.  Does it do that?
Comment 4 Matthew Lenz 2003-04-07 08:51:47 EDT
[root@localhost root]# /usr/bin/smbclient //Jason/HPOffice mypasswordhere -W
metroexpressinc -N -P -c quit -U metroexpressinc/myusernamehere
added interface ip= bcast= nmask=
Got a positive name query response from ( )
Domain=[METROEXPRESSINCM] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

Looks good to me.
Comment 5 Tim Waugh 2003-04-07 09:33:56 EDT
Created attachment 90950 [details]

Please save this as /usr/share/printconf/util/addQueue.py
Comment 6 Tim Waugh 2003-04-07 09:34:38 EDT
Created attachment 90951 [details]

Please save this as /usr/share/printconf/util/backend.py

When you have both those files, please try the config tool again and see if
it's any better.  Thanks.
Comment 7 Matthew Lenz 2003-04-07 10:27:00 EDT
Yes, now it works as expected.  I printed a test page and everything looks correct.
Comment 8 Tim Waugh 2003-04-07 10:32:33 EDT
Fixed package is redhat-config-printer-0.6.52-1, which will shortly appear in
rawhide.  Thanks for testing.
Comment 9 Tim Waugh 2003-07-07 12:36:35 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.