This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 880324 - rhevm-installation: we check if iscsi Export domain exists in the setup after clearing tasks and stopping jboss
rhevm-installation: we check if iscsi Export domain exists in the setup after...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.1.4
Assigned To: Moran Goldboim
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 12:16 EST by Dafna Ron
Modified: 2013-03-04 06:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 06:49:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
sgrinber: Triaged+


Attachments (Terms of Use)
log (58.02 KB, application/octet-stream)
2012-11-26 12:16 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-11-26 12:16:10 EST
Created attachment 652129 [details]
log

Description of problem:

currently we are checking for 2.2 dc/cluster -> check running tasks -> stop jboss -> check if we have iscsi export domain
I think that we should check if iscsi export exists at the same time we check 2.2 DC/Cluster so that user does not have to start jboss manually if they have to detach the storage

Version-Release number of selected component (if applicable):

3.0 -> 24.4

How reproducible:

100%

Steps to Reproduce:
1. add iscsi export domain and 2.2 cluser/dc in your 3.0 setup + have running tasks
2. start upgrade -> remove 2.2 dc/cluster when it fails on that error
3. start upgrade -> agree to stop tasks
  
Actual results:

we fail upgrade because we have iscsi export domain. 
use has to manually start jboss to remove the domain and restart the upgrade

Expected results:

we should check if iscsi export domain exists at the same time we check for 2.2 cluster/DC

Additional info: upgrade log

uring the upgrade process, RHEV Manager  will not be accessible.
All existing running virtual machines will continue but you will not be able to
start or stop any new virtual machines during the process.

Would you like to proceed? (yes|no): yes
Stopping ovirt-engine service...                         [ DONE ]
Stopping DB related services...                          [ DONE ]

Info: The following tasks have been found running in the system: 

System Tasks:
-----
Task ID: 2
Task name: AddVmFromTemplate
Task description: Adding a virtual machine based on a template
-----
Task ID: 2
Task name: AddVmFromTemplate
Task description: Adding a virtual machine based on a template
-----
Task ID: 2
Task name: AddVmFromTemplate
Task description: Adding a virtual machine based on a template




[ Nov 26 18:38:07 ] Would you like to proceed and try to stop tasks automatically?
(Answering 'no' will stop the upgrade)? (yes|no): yes

[ Nov 26 18:38:43 ] System will try to clear tasks during the next 3 minutes.

Pre-upgrade validations...                               [ ERROR ]
Error: The current system contains a block (iSCSI/Fibre Channel) Export Storage Domain which is no longer supported.
Please remove all such Export Storage Domains before proceeding with the upgrade process.


Error: Upgrade failed.
Comment 3 Chris Negus 2013-02-25 09:24:52 EST
I added this note to the RHEVM 3.0-3.1 Upgrade procedure:

* No upgrade with iSCSI export domain (RHEV 2.2)―Upgrades of RHEV 3.0 environments that include an iSCSI export domain will fail. Before doing the upgrade, start the jbossas service manually, remove the domain, and restart the upgrade. See BZ#880324 for details.

Note You need to log in before you can comment on or make changes to this bug.