Bug 880374 - /etc/cron.daily/0logwatch looks in /usr/share/logwatch/defaults.conf/logwatch.conf but does not look in /etc/logwatch/conf/logwatch.conf
/etc/cron.daily/0logwatch looks in /usr/share/logwatch/defaults.conf/logwatch...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch (Show other bugs)
6.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Jan Synacek
BaseOS QE - Apps
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 15:34 EST by Lee Whatley
Modified: 2015-10-12 09:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 09:48:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
[Patch] update 0logwatch cron daily (653 bytes, patch)
2012-11-28 05:10 EST, Jan Synacek
no flags Details | Diff

  None (edit)
Description Lee Whatley 2012-11-26 15:34:01 EST
Description of problem:

/etc/cron.daily/0logwatch looks in /usr/share/logwatch/defaults.conf/logwatch.conf but does not look in /etc/logwatch/conf/logwatch.conf

So if you don't want to turn off daily reporting, you have to set "DailyReport=no" in the /usr/share file rather than in the /etc file.  The comments in the /usr/share file state that it contains all of the default values for logwatch, whereas the /etc file states that you should put all "local configuration options" there.

Version-Release number of selected component (if applicable):

all (including RHEL5)

How reproducible:

always

Steps to Reproduce:
1. Add "DailyReport=no" to /etc/logwatch/conf/logwatch.conf
2. Wait for /etc/cron.daily/0logwatch to run
3. See that the daily report was generated
  
Actual results:

logwatch is run via cron and the daily report is generated.

Expected results:

logwatch does not run daily via cron

Additional info:
Comment 1 Lee Whatley 2012-11-26 15:50:24 EST
The 2nd paragraph, first sentence of the "Description of problem" section should read, "So if you want to turn off daily reporting..."  I had an extra "don't" in the sentence which might cause some confusion.  Sorry about that!
Comment 3 Jan Synacek 2012-11-28 05:10:39 EST
Created attachment 653411 [details]
[Patch] update 0logwatch cron daily

Now the script searches /etc/logwatch/conf/logwatch.conf as well.

This is sort of a workround rather than a patch, as the script itself is generated during the building process.
Comment 4 RHEL Product and Program Management 2013-10-13 20:14:03 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.