Bug 880409 - "ls" won't work after fusermount and pm-hibernate
"ls" won't work after fusermount and pm-hibernate
Status: CLOSED DUPLICATE of bug 880428
Product: Fedora
Classification: Fedora
Component: fuse-sshfs (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 17:38 EST by masterid2
Modified: 2012-12-05 23:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-05 09:30:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description masterid2 2012-11-26 17:38:54 EST
Description of problem:
"ls" won't work after fusermount and pm-hibernate
This can happen in all Fedora releases.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.sshfs mount a remote directory
2.pm-hibernate
3.awake ur system after a while (maybe 1 hour)
  
Actual results:
List directory commands like "ls" won't work.
File browsers won't work either.
No respond from those programs.

Expected results:
They work properly.

Additional info:
Linux 3.6.7-4.fc17.x86_64 #1 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 gil cattaneo 2012-11-26 18:55:57 EST
hibernate is a library used for object/relational persistence and query service for Java used for e.g by jboss-as
with "ls" what you do want done?
regards
Comment 2 masterid2 2012-11-26 19:00:38 EST
Sorry, I chose a wrong Component: hibernate.

It should be "pm-utils". It is a power manager problem.

With "ls" of course I want to list the files...
Comment 3 gil cattaneo 2012-11-26 19:07:49 EST
no problems. maybe you're looking for hibernate script from http://www.tuxonice.net/
regards
Comment 4 masterid2 2012-11-26 19:08:12 EST
"Good" redhat developers, just change it to "notabug".

What is it? A good feature???
Comment 5 masterid2 2012-11-26 19:14:58 EST
(In reply to comment #3)
> no problems. maybe you're looking for hibernate script from
> http://www.tuxonice.net/
> regards

I am not looking for this. It is not a Redhat official component and I do not want to compile it by myself.
Comment 6 Stanislav Ochotnicky 2012-12-05 09:14:22 EST
(In reply to comment #4)
> "Good" redhat developers, just change it to "notabug".
> 
> What is it? A good feature???

You filed a bug against wrong component. Up until *this* point there was no Red Hat developer involved.

Bug should have been filed for fuse-sshfs (I've reset the compoent). I'd suggest clarifying what is the problem. My assumption is that sshfs simply doesn't reconnect after losing connection when in hibernation. In other words this most likely has nothing to do with hibernation/pm. If you disconnect from network you'll get the same results presumably.
Comment 7 Peter Lemenkov 2012-12-05 09:30:23 EST
(In reply to comment #6)

> Bug should have been filed for fuse-sshfs (I've reset the compoent). I'd
> suggest clarifying what is the problem. My assumption is that sshfs simply
> doesn't reconnect after losing connection when in hibernation. In other
> words this most likely has nothing to do with hibernation/pm. If you
> disconnect from network you'll get the same results presumably.

I'm afraid we can't do much here. And I really afraid I'm going to re-close it again.

If connection is lost then a user's manual interaction is required in most cases to restore a broken SSH connection (except the case where you provided a public key w/o password protection - man ssh-keygen, ssh-copy-id). However even in this case what masterid2@gmail.com requested from us is an additional (currently not implemented) functionality which should not be asked here but rather in upstream.

* http://fuse.sourceforge.net/sshfs.html
Comment 8 masterid2 2012-12-05 16:11:01 EST
(In reply to comment #7)
> (In reply to comment #6)
> 
> > Bug should have been filed for fuse-sshfs (I've reset the compoent). I'd
> > suggest clarifying what is the problem. My assumption is that sshfs simply
> > doesn't reconnect after losing connection when in hibernation. In other
> > words this most likely has nothing to do with hibernation/pm. If you
> > disconnect from network you'll get the same results presumably.
> 
> I'm afraid we can't do much here. And I really afraid I'm going to re-close
> it again.
> 
> If connection is lost then a user's manual interaction is required in most
> cases to restore a broken SSH connection (except the case where you provided
> a public key w/o password protection - man ssh-keygen, ssh-copy-id). However
> even in this case what masterid2@gmail.com requested from us is an
> additional (currently not implemented) functionality which should not be
> asked here but rather in upstream.
> 
> * http://fuse.sourceforge.net/sshfs.html

I have already marked this one as duplicate.

I asked fuse-sshfs as well but got no reply.
Comment 9 Peter Lemenkov 2012-12-05 23:33:55 EST

*** This bug has been marked as a duplicate of bug 880428 ***

Note You need to log in before you can comment on or make changes to this bug.