Bug 88049 - GTK+ Applications hang at while running Xinerama.
GTK+ Applications hang at while running Xinerama.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-04 16:37 EST by Ted
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 05:59:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted 2003-04-04 16:37:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I've noticed a lot of bugginess when running applications that use the gtk
libraries with my redhat 9 workstation that is using Xinerama.  At first I
thought it was a memory problem with my machine (since my non xinerama computer
was not having the same problems), but after running memtest and a variety of
other apps to test the hardware turned up with nothing.  When I switched off
xinerama support on the workstation the gtk+ apps operated normally.  Non Gtk+
apps do not seem to be affected by this at all so I just am assuming it is a bug
with gtk and not xinerama.

Version-Release number of selected component (if applicable):
gtk+-1.2.10-25

How reproducible:
Sometimes

Steps to Reproduce:
1. Install RedHat 9
2. Configure X11 to run a multiheaded display.
3. Start and then exit a gtk+ applicaton several times (such as the gimp).
4. Gimp most noticeably will usually hang on it's initialization screen.


Actual Results:  The program will hang and can only be terminated with a kill -9.

Expected Results:  The program should load and run without hanging.

Additional info:

My computer is a Dell Dimension  XPS T500
256 megs ram
2 Geforce 2 video cards (running the nv driver).
Comment 1 Owen Taylor 2003-04-04 16:51:06 EST
GTK+-1.2 apps, such as the GIMP don't use the Xinerama APIs at all,
or have any special code for Xinerama so it's almost certainly an 
Xlib or X server bug.
Comment 2 Mike A. Harris 2003-04-04 17:19:06 EST
This problem could be caused by anything.  I'll investigate it once
I've received numerous reports from various people experiencing the same
problem using Xinerama, thus indicating it is a common problem and not
one localized to a specific setup.
Comment 3 Mike A. Harris 2003-04-28 05:59:10 EDT
No other users have reported Xinerama related problems as described above,
and there isn't any specific useful information in the above bug report to
describe exactly how to roproduce any particular problem 100%, so there isn't
really anything that we can do about it anyway without a more specific bug
report, including a stack backtrace, etc.

If you are still experiencing these problems, please seek technical support
on the xfree86@xfree86.org mailing list, and if a real bug can be discovered
in XFree86, then file a bug report in XFree86 bugzilla at:

    http://bugs.xfree86.org

If you do determine a real specific bug and report it upstream, feel free
to add a URL here to the upstream bug report and I'll track the upstream
bug.


Comment 4 Gregory P. Smith 2004-03-01 18:26:58 EST
http://bugs.xfree86.org/show_bug.cgi?id=628

and

http://bugs.xfree86.org/show_bug.cgi?id=438

could be related to this.

Note You need to log in before you can comment on or make changes to this bug.