Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 880592 - systemd-journald address space usage gone crazy (persistent storage)
Summary: systemd-journald address space usage gone crazy (persistent storage)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-27 12:00 UTC by Paolo Bonzini
Modified: 2013-03-07 16:55 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-07 16:55:08 UTC
Type: Bug


Attachments (Terms of Use)
/proc/PID/maps file for systemd-journald (577.95 KB, text/plain)
2012-11-27 12:00 UTC, Paolo Bonzini
no flags Details

Description Paolo Bonzini 2012-11-27 12:00:01 UTC
Created attachment 652639 [details]
/proc/PID/maps file for systemd-journald

Description of problem:
I noticed that top was reporting 16.5G of address space used by journald.
My /etc/systemd/journald.conf has the following:

[Journal]
Storage=persistent

/proc/286/maps.log has a few thousand 4100K mappings of journal files, and running "strace -e mmap,munmap -p 286" confirmed the leak:

mmap(NULL, 4198400, PROT_READ|PROT_WRITE, MAP_SHARED, 14, 0x1692000) = 0x7fc90247e000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fc90247d000
munmap(0x7fc90247d000, 4096)            = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fc90247d000
munmap(0x7fc90247d000, 4096)            = 0
...
mmap(NULL, 4198400, PROT_READ|PROT_WRITE, MAP_SHARED, 14, 0x1693000) = 0x7fc90207d000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fc90207c000
munmap(0x7fc90207c000, 4096)            = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fc90207c000
munmap(0x7fc90207c000, 4096)            = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fc90207c000
...

Version-Release number of selected component (if applicable):
Unfortunately I noticed this only after an update, but it should be 195-4 or -5 based on the uptime of the system.

Comment 1 Lennart Poettering 2013-03-07 16:18:23 UTC
Which version of systemd is this? Can you reproduce this with the current version from F18?

Comment 2 Paolo Bonzini 2013-03-07 16:55:08 UTC
I cannot reproduce it with systemd-197-1.fc18.2.x86_64.

Seems to be fixed.


Note You need to log in before you can comment on or make changes to this bug.