Bug 880745 - Upgrade from 3.0.x to 3.1 requires a standalone utility that enables to review async tasks and clean them
Upgrade from 3.0.x to 3.1 requires a standalone utility that enables to revie...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.1
Assigned To: Yair Zaslavsky
Pavel Stehlik
infra
: Improvement, ZStream
Depends On:
Blocks: 883388 884794
  Show dependency treegraph
 
Reported: 2012-11-27 12:44 EST by Yair Zaslavsky
Modified: 2016-02-10 14:38 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
A new tool, engine-async-tasks-cli, is available. This standalone utility is for erasing asynchronous tasks on upgrade from Red Hat Enterprise Virtualization 3.0 to 3.1.
Story Points: ---
Clone Of:
: 884794 (view as bug list)
Environment:
Last Closed: 2013-01-15 10:13:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yair Zaslavsky 2012-11-27 12:44:08 EST
Description of problem:

Upgrade from 3.0.x to 3.1 requires a tool that will provide information to the user about running tasks, and if it is safe to clear them.

The tool should include the following:

- list all tasks in details
- list all zombie tasks (according to the zombie task period as defined at vdc_options)
- clear task (by task id)
   Here we need to define carefully what is cleared when the task is not a zombie task)
- clear all zombies


Open issues -

For Clear all zombies - Should we check of locked entities ?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 15 errata-xmlrpc 2013-01-15 10:13:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0003.html

Note You need to log in before you can comment on or make changes to this bug.