Bug 88084 - rhn-applet crashes when "Configuration" is selected
rhn-applet crashes when "Configuration" is selected
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Robin Norwood
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-05 06:59 EST by Andrew Sobala
Modified: 2007-04-18 12:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 14:11:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Sobala 2003-04-05 06:59:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
- Add rhn-applet to the panel
- Right click, choose "configuration"
- Crash

Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-0.9.0.1

How reproducible:
Always

Additional info:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1074120768 (LWP 2084)]
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0xffffe002 in ?? ()
#0  0xffffe002 in ?? ()
#1  0x407d1fa7 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x4126af2d in html_view_accessible_new () from /usr/lib/libgtkhtml-2.so.0
#4  0x4126ab0d in html_view_accessible_new () from /usr/lib/libgtkhtml-2.so.0
#5  0x40bbdb27 in atk_object_initialize () from /usr/lib/libatk-1.0.so.0
#6  0x4126aa60 in html_view_accessible_new () from /usr/lib/libgtkhtml-2.so.0
#7  0x4126b28a in html_view_accessible_factory_get_type ()
   from /usr/lib/libgtkhtml-2.so.0
#8  0x40bbe8ad in atk_object_factory_create_accessible ()
   from /usr/lib/libatk-1.0.so.0
#9  0x40ab3575 in gtk_widget_get_accessible ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0x41269157 in html_view_new () from /usr/lib/libgtkhtml-2.so.0
#11 0x40ab3486 in gtk_widget_get_accessible ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x4112635e in gail_container_new ()
   from /usr/lib/gtk-2.0/modules/libgail.so
#13 0x402c8994 in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#14 0x402b4ed7 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#15 0x402c7983 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#16 0x402c69a8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x402c6be4 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#18 0x40967751 in gtk_container_add () from /usr/lib/libgtk-x11-2.0.so.0
#19 0x40ea3a5c in pygtk_generic_cell_renderer_new ()
   from /usr/lib/python2.2/site-packages/gtk-2.0/gtk/_gtkmodule.so
#20 0x080d0e8e in PyCFunction_Call ()
#21 0x080b3797 in PyObject_Call ()
#22 0x0807c905 in PyEval_GetFuncDesc ()
#23 0x0807a613 in PyEval_EvalCode ()
#24 0x0807b0ce in PyEval_EvalCodeEx ()
#25 0x080c447c in PyFunction_SetClosure ()
#26 0x080b3797 in PyObject_Call ()
#27 0x080ba4ab in PyMethod_New ()
#28 0x080b3797 in PyObject_Call ()
#29 0x0807c2d0 in PyEval_CallObjectWithKeywords ()
#30 0x080b631d in PyInstance_New ()
#31 0x080b3797 in PyObject_Call ()
#32 0x0807c905 in PyEval_GetFuncDesc ()
#33 0x0807a525 in PyEval_EvalCode ()
#34 0x0807b0ce in PyEval_EvalCodeEx ()
#35 0x080c447c in PyFunction_SetClosure ()
#36 0x080b3797 in PyObject_Call ()
#37 0x080ba4ab in PyMethod_New ()
#38 0x080b3797 in PyObject_Call ()
#39 0x0807c2d0 in PyEval_CallObjectWithKeywords ()
#40 0x080b374e in PyObject_CallObject ()
#41 0x402950f5 in pyg_value_as_pyobject ()
   from /usr/lib/python2.2/site-packages/gtk-2.0/gobjectmodule.so
#42 0x402b4ed7 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#43 0x402c7983 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#44 0x402c69a8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#45 0x402c6be4 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#46 0x40aac8ed in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#47 0x409d6682 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#48 0x409d58ff in _gtk_menu_shell_activate () from /usr/lib/libgtk-x11-2.0.so.0
#49 0x409ced6b in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#50 0x409c6c2f in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#51 0x402b5247 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#52 0x402b4ed7 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#53 0x402c7439 in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#54 0x402c67af in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#55 0x402c6be4 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#56 0x40aac6fb in gtk_widget_send_expose () from /usr/lib/libgtk-x11-2.0.so.0
#57 0x409c6a27 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#58 0x409c5725 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#59 0x40b841a5 in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#60 0x40303b35 in g_get_current_time () from /usr/lib/libglib-2.0.so.0
#61 0x40304b78 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#62 0x40304e8d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#63 0x4030558f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#64 0x409c4f5f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#65 0x40ec68cc in pygtk_generic_cell_renderer_new ()
   from /usr/lib/python2.2/site-packages/gtk-2.0/gtk/_gtkmodule.so
#66 0x0807c546 in PyEval_GetFuncDesc ()
#67 0x0807a634 in PyEval_EvalCode ()
#68 0x0807b0ce in PyEval_EvalCodeEx ()
#69 0x0807c62b in PyEval_GetFuncDesc ()
#70 0x0807a5a3 in PyEval_EvalCode ()
#71 0x0807b0ce in PyEval_EvalCodeEx ()
#72 0x0807c62b in PyEval_GetFuncDesc ()
#73 0x0807a5a3 in PyEval_EvalCode ()
#74 0x0807b0ce in PyEval_EvalCodeEx ()
#75 0x08077fc5 in PyEval_EvalCode ()
#76 0x08097e29 in PyRun_FileExFlags ()
#77 0x08096d90 in PyRun_SimpleFileExFlags ()
#78 0x080966da in PyRun_AnyFileExFlags ()
#79 0x08053a19 in Py_Main ()
#80 0x08053469 in main ()
#81 0x42015574 in __libc_start_main () from /lib/tls/libc.so.6
Comment 1 Daniel Veillard 2003-04-07 13:55:45 EDT
I can't reproduce this. Can you upgrade to a pristine version of Red Hat 9,
this seems to crash within the Gnome libraries and I can't guess how and
why this crashed there.

Daniel
Comment 2 Andrew Sobala 2003-04-08 10:25:38 EDT
This is pristine RH9. I haven't added any of my GNOME CVS stuff yet.

If you want me to do any gdb stuff for you to get more information, I can.
Comment 3 John Elsworth 2005-05-31 17:33:56 EDT
The Application 'rhn-applet' has quit unexpectedly

FC3
rhn-applet-2.1.16-1

run rhn-applet-gui
right click
configuration...
crash
Comment 4 Bill Nottingham 2006-08-05 01:10:59 EDT
Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks.

Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
They are maintained by the Fedora Legacy project (http://www.fedoralegacy.org/)
for security updates only. If this is a security issue, please reassign to the
'Fedora Legacy' product in bugzilla. Please note that Legacy security update
support for these products will stop on December 31st, 2006.

If this is not a security issue, please check if this issue is still present
in a current Fedora Core release. If so, please change the product and version
to match, and check the box indicating that the requested information has been
provided.

If you are currently still running Red Hat Linux 7.3 or 9, please note that
Fedora Legacy security update support for these products will stop on December
31st, 2006. You are strongly advised to upgrade to a current Fedora Core release
or Red Hat Enterprise Linux or comparable. Some information on which option may
be right for you is available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Any bug still open against Red Hat Linux 7.3 or 9 at the end of 2006 will be
closed 'CANTFIX'. Again, if this bug still exists in a current release, or is a
security issue, please change the product as necessary. We thank you for your
help, and apologize again that we haven't handled these issues to this point.
Comment 6 Bill Nottingham 2007-01-02 14:11:40 EST
Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
f you are currently still running Red Hat Linux 7.3 or 9, you are strongly
advised to upgrade to a current Fedora Core release or Red Hat Enterprise Linux
or comparable. Some information on which option may be right for you is
available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.