Bug 880861 - [abrt] libvirt-daemon-0.10.2.1-3.fc18: strlen: Process /usr/sbin/libvirtd was killed by signal 11 (SIGSEGV)
[abrt] libvirt-daemon-0.10.2.1-3.fc18: strlen: Process /usr/sbin/libvirtd was...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
abrt_hash:36662d0ad05181b621bf8c51f94...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 18:10 EST by Gerard Ryan
Modified: 2013-01-27 16:24 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-27 16:24:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.88 KB, text/plain)
2012-11-27 18:10 EST, Gerard Ryan
no flags Details
File: cgroup (129 bytes, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: core_backtrace (2.06 KB, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: dso_list (8.54 KB, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: environ (299 bytes, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: maps (42.51 KB, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: open_fds (833 bytes, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details
File: var_log_messages (1.10 KB, text/plain)
2012-11-27 18:11 EST, Gerard Ryan
no flags Details

  None (edit)
Description Gerard Ryan 2012-11-27 18:10:51 EST
Description of problem:
I installed F18 beta in gnome-boxes, used it for a bit, and then went to power off. It appeared off (nothing was happening and the screen was blank). I closed gnome-boxes, and this abrt showed up.

Version-Release number of selected component:
libvirt-daemon-0.10.2.1-3.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/sbin/libvirtd --timeout=30
crash_function: strlen
executable:     /usr/sbin/libvirtd
kernel:         3.6.7-5.fc18.x86_64
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 strlen at ../sysdeps/x86_64/strlen.S:31
 #1 setfilecon_raw_internal at setfilecon.c:12
 #2 virSecuritySELinuxSetFileconHelper at security/security_selinux.c:796
 #3 virSecurityStackSetSavedStateLabel at security/security_stack.c:319
 #4 qemuMigrationToFile at qemu/qemu_migration.c:3234
 #5 qemuDomainSaveInternal at qemu/qemu_driver.c:2810
 #6 qemuDomainManagedSave at qemu/qemu_driver.c:3019
 #7 virDomainManagedSave at libvirt.c:17531
 #8 remoteDispatchDomainManagedSave at remote_dispatch.h:3210
 #9 remoteDispatchDomainManagedSaveHelper at remote_dispatch.h:3188
Comment 1 Gerard Ryan 2012-11-27 18:10:58 EST
Created attachment 653180 [details]
File: backtrace
Comment 2 Gerard Ryan 2012-11-27 18:11:00 EST
Created attachment 653181 [details]
File: cgroup
Comment 3 Gerard Ryan 2012-11-27 18:11:02 EST
Created attachment 653182 [details]
File: core_backtrace
Comment 4 Gerard Ryan 2012-11-27 18:11:04 EST
Created attachment 653183 [details]
File: dso_list
Comment 5 Gerard Ryan 2012-11-27 18:11:06 EST
Created attachment 653184 [details]
File: environ
Comment 6 Gerard Ryan 2012-11-27 18:11:09 EST
Created attachment 653185 [details]
File: limits
Comment 7 Gerard Ryan 2012-11-27 18:11:11 EST
Created attachment 653186 [details]
File: maps
Comment 8 Gerard Ryan 2012-11-27 18:11:13 EST
Created attachment 653187 [details]
File: open_fds
Comment 9 Gerard Ryan 2012-11-27 18:11:16 EST
Created attachment 653188 [details]
File: proc_pid_status
Comment 10 Gerard Ryan 2012-11-27 18:11:18 EST
Created attachment 653189 [details]
File: var_log_messages
Comment 11 Cole Robinson 2013-01-27 16:24:49 EST
there was a major libvirt update in F18 after this bug was filed, and since I haven't seen other reports of this I assume it is fixed. Closing as WORKSFORME, anyone please reopen if you can reproduce.

Note You need to log in before you can comment on or make changes to this bug.