Bug 880862 - openstack-quantum-openvswitch dependents on openvswitch
openstack-quantum-openvswitch dependents on openvswitch
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: openstack-quantum (Show other bugs)
el6
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bob Kukura
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 18:12 EST by Karol Perkowski
Modified: 2014-02-27 18:17 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-26 13:57:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karol Perkowski 2012-11-27 18:12:32 EST
Description of problem:

openstack-quantum-openvswitch depends on openvswitch, which isn't in epel.

How reproducible:

Try to install the package.

Steps to Reproduce:
1. yum install openstack-quantum-openvswitch
2. yum install openvswitch
  
Actual results:

[root@openstack-node1 07-openstack-controller]# yum -y install openstack-quantum-openvswitch
Loaded plugins: security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openstack-quantum-openvswitch.noarch 0:2012.2-2.el6 will be installed
--> Processing Dependency: openstack-quantum = 2012.2-2.el6 for package: openstack-quantum-openvswitch-2012.2-2.el6.noarch
--> Processing Dependency: openvswitch for package: openstack-quantum-openvswitch-2012.2-2.el6.noarch
--> Running transaction check
---> Package openstack-quantum.noarch 0:2012.2-2.el6 will be installed
--> Processing Dependency: python-quantum = 2012.2-2.el6 for package: openstack-quantum-2012.2-2.el6.noarch
---> Package openstack-quantum-openvswitch.noarch 0:2012.2-2.el6 will be installed
--> Processing Dependency: openvswitch for package: openstack-quantum-openvswitch-2012.2-2.el6.noarch
--> Running transaction check
---> Package openstack-quantum-openvswitch.noarch 0:2012.2-2.el6 will be installed
--> Processing Dependency: openvswitch for package: openstack-quantum-openvswitch-2012.2-2.el6.noarch
---> Package python-quantum.noarch 0:2012.2-2.el6 will be installed
--> Finished Dependency Resolution
Error: Package: openstack-quantum-openvswitch-2012.2-2.el6.noarch (epel)
           Requires: openvswitch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Install openvswitch.

Additional info:
Comment 1 Tuomo Soini 2013-05-23 04:51:50 EDT
Is there any progress with this issue?

If there is no openswitch in epel I suggest removing openstack-quantum-openswitch sub-package.
Comment 2 Pádraig Brady 2013-05-26 13:57:57 EDT
openvswitch is provided now from RDO (http://openstack.redhat.com/)

Note You need to log in before you can comment on or make changes to this bug.