Bug 88138 - swap on exluded disk still mkswap'ed
swap on exluded disk still mkswap'ed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-06 11:49 EDT by Paul Wouters
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2003-04-06 11:49:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When installing with two disks with redhat installs on the, and 
performing a "fresh install" (no upgrade) on hda using autopartition,
hdb shows up with the current partitions on it, though without mountpoints. This
is confusing since it seems to suggest these will
be installed/created as well.
When I continued, it actually warned that hdb3 (a swap partition) is
going to get destroyed. It then also (I believe) mkswap'ed it.

I think disks that have been explicitely excluded should not show up
in any partitioning selection later on, and should also not be touched
by mkswap.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.put two disk with redhat isntallations in a machine
2. install redhat on disk 1

    

Additional info:
Comment 1 Stan Bubrouski 2003-06-30 21:26:06 EDT
This is not limited to happening on /dev/hda, I did custom on
a fresh install and disk druid selected two partitions on my
/dev/hdc as being swap...one of them was an old 20 GB Ext2
partition.  But it gets worse, I edited those partions and
selected the Do Not Touch This Partition option or whatever
and Disk Druid unchecked them as partions to be formatted.  I
proceeded to setup my partition configuration on /dev/hdb,
but when it came time to install the packages I got an error
about how it could not modify /dev/hdc5 (it tried to mkswap my
two other partions on /dev/hdc even though I removed those
from Disk Druid (I thought).  It then told me to click OK and
reboot... this is not how it is suppost to be...I cannot install
RH9 atm.
Comment 2 Stan Bubrouski 2003-06-30 21:27:08 EDT
Oh i forgot to mention I was installing on /dev/hdb and it still
tried to create swap partions on /dev/hdc just to clear up my
merky description.
Comment 3 Jeremy Katz 2004-10-04 23:08:25 EDT
This has been changedin recent releases.

Note You need to log in before you can comment on or make changes to this bug.