Bug 881546 - Lorax 18.22-6 exits with traceback on x86_64
Lorax 18.22-6 exits with traceback on x86_64
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-28 23:34 EST by Tim Flink
Modified: 2013-02-04 13:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 13:24:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-11-28 23:34:39 EST
I've attempted to build several images with pungi on x86_64 with lorax-18.22-6.fc18 and each one has halted with the following error:

template command error in x86.tmpl:
  installupgradeinitrd boot/upgrade-3.6.7-5.fc18.x86_64.img images/pxeboot/upgrade.img
  TypeError: installupgradeinitrd() takes exactly 4 arguments (3 given)
Traceback (most recent call last):
  File "/usr/bin/pungi", line 256, in <module>
     main()
  File "/usr/bin/pungi", line 146, in main
    mypungi.doBuildinstall()
  File "/usr/lib/python2.7/site-packages/pypungi/__init__.py", line 913, in doBuildinstall
    workdir=workdir, outputdir=outputdir)
  File "/usr/lib/python2.7/site-packages/pylorax/__init__.py", line 301, in run
    treebuilder.build()
  File "/usr/lib/python2.7/site-packages/pylorax/treebuilder.py", line 218, in build
    self._runner.run(templatefile, kernels=self.kernels)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 176, in run
    self._run(commands)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 195, in _run
    f(*args)
TypeError: installupgradeinitrd() takes exactly 4 arguments (3 given)

The command I'm using is:

pungi --force --nosource --nodebuginfo -G -C -B -I --force --flavor Fedora --name Fedora --ver 18 -c /tmp/fedora-install-fedora.ks

I'm also seeing this building with lorax, so I don't think it's a pungi issue - it's just the log I had easiest access to.

This is breaking all of my image builds but it sounds like the rel-eng composes are working fine with this lorax, so I'm not proposing as a blocker at this time.
Comment 1 Fedora Admin XMLRPC Client 2013-02-04 10:04:36 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Brian Lane 2013-02-04 13:24:49 EST
Seems to be working fine with latest build on f18 host (lorax-18.30-1)

Note You need to log in before you can comment on or make changes to this bug.