Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 881662 - Terminal session is not restored
Summary: Terminal session is not restored
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar-terminal
Version: 18
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-29 09:47 UTC by Simon Schampijer
Modified: 2012-12-07 04:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-07 04:26:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Simon Schampijer 2012-11-29 09:47:58 UTC
Description of problem:

The session state is not saved, when resuming an old Terminal session the tabs are not restored.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open Terminal activity
2. create a second tab, close activity
3. resume it
  
Actual results:
Only one tab is shown.

Expected results:
Bit tabs are restored.

Additional info:
upstream Terminal activity bug: http://bugs.sugarlabs.org/ticket/4131

This root cause is an upstream bug in vte: https://bugzilla.gnome.org/show_bug.cgi?id=676999

Fix landed in vte-0-34: http://git.gnome.org/browse/vte/commit/?h=vte-0-34&id=2ba27999b537300f4beb92ca27830fbd4197740e

Comment 1 Fedora Update System 2012-11-29 10:44:55 UTC
vte3-0.34.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/vte3-0.34.2-3.fc18

Comment 2 Fedora Update System 2012-11-30 06:33:42 UTC
Package vte3-0.34.2-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vte3-0.34.2-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19364/vte3-0.34.2-3.fc18
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2012-12-07 04:26:21 UTC
vte3-0.34.2-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.