This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 881830 - KickstartFileSyncTask won't re-create content of /var/lib/rhn/kickstarts/wizzard directory
KickstartFileSyncTask won't re-create content of /var/lib/rhn/kickstarts/wizz...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Pavel Studeník
:
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2012-11-29 11:23 EST by Milan Zazrivec
Modified: 2013-03-04 07:57 EST (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-113
Doc Type: Bug Fix
Doc Text:
Consequence: If content of /var/lib/rhn/kickstarts/wizzard directory gets deleted, taskomatic fails to re-create it. Result: Possibly deleted content of /var/lib/rhn/kickstarts/wizzard directory will be correctly re-created by taskomatic.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 07:57:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2012-11-29 11:23:25 EST
Description of problem:
The following directory on RHN Satellite:

    /var/lib/rhn/kickstarts/wizzard

contains kickstart files for every kickstart profile defined on RHN Satellite.
Should the content of this directory be deleted (which happens for example
automatically during RHN Satellite upgrade), KickstartFileSyncTask will
not re-create its content as it should (i.e. the task which should
be syncing the kickstart files to disk will not sync anything).

Version-Release number of selected component (if applicable):
spacewalk-java-1.7.54-103

How reproducible:
Deterministic

Steps to Reproduce:
1. Satellite 5.5, create a kickstart profile
2. Check /var/lib/rhn/kickstarts/wizzard directory, a kickstart file
for the profile should be created by tomcat.
3. Delete the kickstart file from the step 2.
4. Manually execute KickstartFileSyncTask from:
    rhn/admin/BunchDetail.do?label=kickstartfile-sync-bunch
5. See whether taskomatic re-created the deleted file.
  
Actual results:
The deleted kickstart file will never be re-created by taskomatic.

Expected results:
The deleted file is re-created by taskomatic

Additional info:
Change in behavior was introduced by bug #863479 and the following commit:

http://git.fedorahosted.org/cgit/spacewalk.git/commit/?id=1c7490e39d859179573e2c735e82bc3acb8e3f05
Comment 2 Tomas Lestach 2012-12-03 08:35:20 EST
create /var/lib/rhn/kickstarts/wizard/*.cfg files if missing by the KickstartFileSyncTask ...
+ bonus: fix the query returning all kickstart data to contain only unique entries

spacewalk.git: f8559ee73b52ba4959828459b8c68ed10ef27b2e
Comment 7 errata-xmlrpc 2013-03-04 07:57:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0583.html

Note You need to log in before you can comment on or make changes to this bug.