Bug 882247 - forgot username and reset password: no confirmation and user action not clear
forgot username and reset password: no confirmation and user action not clear
Status: CLOSED UPSTREAM
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: David Davis
SAM QE List
:
Depends On: 860301
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 08:48 EST by Tom McKay
Modified: 2012-12-18 09:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 860301
Environment:
Last Closed: 2012-12-18 09:10:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-11-30 08:48:37 EST
+++ This bug was initially created as a clone of Bug #860301 +++

Created attachment 617065 [details]
reset password

Description of problem:
When selecting "Forgot Username or Password?" user is not taken to a confirmation screen. An email is sent in the background but the UI does not change. It feels like nothing has happened.

Also it is not at all clear what the circle icon does.


Version-Release number of selected component (if applicable):
v.1.1
[root@qeblade40 Dev]# rpm -qa |grep katello
katello-cli-common-1.1.8-5.el6cf.noarch
katello-1.1.12-9.el6cf.noarch
katello-glue-pulp-1.1.12-9.el6cf.noarch
katello-all-1.1.12-9.el6cf.noarch
katello-certs-tools-1.1.8-1.el6cf.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-common-1.1.12-9.el6cf.noarch
katello-selinux-1.1.1-1.el6cf.noarch
katello-configure-1.1.9-4.el6cf.noarch
katello-glue-candlepin-1.1.12-9.el6cf.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-1.1.8-5.el6cf.noarch


How reproducible:
100%

Steps to Reproduce:
1. Go to login screen
2. select "Forgot Username or Password?"
3. complete form and submit

Actual results:


Expected results:
UI should confirm an email has been sent and provide basic instruction to user. Circle icon should be changed to text "Login" or equivalent.

Comment:
This may seem like an RFE but the behavior really feels broken to me, or at least half-baked.

--- Additional comment from Aaron Weitekamp on 2012-09-25 09:59:35 EDT ---

Created attachment 617066 [details]
Forgot username

--- Additional comment from Aaron Weitekamp on 2012-09-25 10:06:43 EDT ---

Also, when a user enters a new password there's no confirmation the password has been changed. Clicking the mysterious circle icon returns a page with text "Unknown action The action 'show' could not be found for UserSessionsController". The only way to login after resetting password is to change the URL in the browser location bar to [myHost]/katello

--- Additional comment from RHEL Product and Program Management on 2012-09-25 10:13:31 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Mike McCune on 2012-10-10 10:33:12 EDT ---

agreed, that page is a bit confusing now since there is zero feedback after a submit.
Comment 1 Tom McKay 2012-11-30 08:50:04 EST
This is a high priority BZ. The lack of confirmation/feedback in the UI when requesting password reset as well as actually resetting the password leads to a very bad user experience.
Comment 2 Jordan OMara 2012-12-11 14:44:22 EST
Upstream fix unsuitable for SAM-1.2 codebase. pushing to 1.3

Note You need to log in before you can comment on or make changes to this bug.