Bug 882299 - Windows 8 guest disks can't be mounted: "The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option."
Windows 8 guest disks can't be mounted: "The NTFS partition is in an unsafe s...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-30 10:53 EST by Richard W.M. Jones
Modified: 2012-12-01 08:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-01 08:26:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-11-30 10:53:06 EST
Description of problem:

Windows 8 guest disks cannot be mounted for write.  ntfs-3g gives the
following error:

mount -o  /dev/sda2 /sysroot/
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

For example in guestfish:

$ guestfish --rw -a /dev/vg_pin/Win8x32 -i
libguestfs: error: mount: /dev/sda2 on / (options: ''): The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

(The same command works if you change --rw to --ro)

This page has a reasonable summary of the issue:
http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.html

We should document this problem, since there's probably no
easy way to work around it.

Version-Release number of selected component (if applicable):

libguestfs 1.19.64

Note You need to log in before you can comment on or make changes to this bug.