Bug 882552 - [abrt] yum-utils-1.1.31-6.fc18: yumRepo.py:387:_ui_id:TypeError: argument of type 'Undefined' is not iterable
[abrt] yum-utils-1.1.31-6.fc18: yumRepo.py:387:_ui_id:TypeError: argument of ...
Status: CLOSED DUPLICATE of bug 870691
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:73f8db921d3e2c2485488f82547...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-01 15:17 EST by marian
Modified: 2012-12-03 02:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 02:44:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: environ (2.84 KB, text/plain)
2012-12-01 15:17 EST, marian
no flags Details
File: dso_list (24 bytes, text/plain)
2012-12-01 15:17 EST, marian
no flags Details
File: executable (22 bytes, text/plain)
2012-12-01 15:17 EST, marian
no flags Details
File: core_backtrace (1.78 KB, text/plain)
2012-12-01 15:18 EST, marian
no flags Details
On this file i commented last repository maybe was mistake. (1.18 KB, application/octet-stream)
2012-12-01 15:31 EST, marian
no flags Details

  None (edit)
Description marian 2012-12-01 15:17:50 EST
Description of problem:
run in terminal yumdownloader --source kernel and on /etc/yum.repos.d not found some URL' fron some repo's and here i remove it some repo from this directory an ok result.

Version-Release number of selected component:
yum-utils-1.1.31-6.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python /usr/bin/yumdownloader --source kernel
kernel:         3.6.7-5.fc18.x86_64

backtrace:
:yumRepo.py:387:_ui_id:TypeError: argument of type 'Undefined' is not iterable
:
:Traceback (most recent call last):
:  File "/usr/bin/yumdownloader", line 335, in <module>
:    util = YumDownloader()
:  File "/usr/bin/yumdownloader", line 73, in __init__
:    self.main()
:  File "/usr/bin/yumdownloader", line 96, in main
:    self.doUtilYumSetup(opts)
:  File "/usr/bin/yumdownloader", line 294, in doUtilYumSetup
:    self._getRepos(doSetup = True)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 722, in _getRepos
:    self._repos.doSetup(thisrepo)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 134, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 84, in retrieveAllMD
:    dl = repo._async and repo._commonLoadRepoXML(repo)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1370, in _commonLoadRepoXML
:    result = self._getFileRepoXML(local, text)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1148, in _getFileRepoXML
:    size=102400) # setting max size as 100K
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 950, in _getFile
:    result = self.grab.urlgrab(misc.to_utf8(relative), local,
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 626, in <lambda>
:    grab = property(lambda self: self._getgrab())
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 621, in _getgrab
:    self._setupGrab()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 586, in _setupGrab
:    urls = self.urls
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 806, in <lambda>
:    urls = property(fget=lambda self: self._geturls(),
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 803, in _geturls
:    self._baseurlSetup()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 769, in _baseurlSetup
:    self.check()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 513, in check
:    'Cannot find a valid baseurl for repo: %s' % self.ui_id
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 387, in _ui_id
:    if '$releasever' in val:
:TypeError: argument of type 'Undefined' is not iterable
:
:Local variables in innermost frame:
:self: <yum.yumRepo.YumRepository object at 0x2de2a50>
:val: <iniparse.config.Undefined object at 0x2eef7d0>
:section_id: 'rpmfusion-free-updates-source'
:ret: 'rpmfusion-free-updates-source'
:ini: <iniparse.ini.INISection object at 0x2eef790>
Comment 1 marian 2012-12-01 15:17:54 EST
Created attachment 655741 [details]
File: environ
Comment 2 marian 2012-12-01 15:17:56 EST
Created attachment 655742 [details]
File: dso_list
Comment 3 marian 2012-12-01 15:17:58 EST
Created attachment 655743 [details]
File: executable
Comment 4 marian 2012-12-01 15:18:00 EST
Created attachment 655744 [details]
File: core_backtrace
Comment 5 marian 2012-12-01 15:31:31 EST
Created attachment 655745 [details]
On this file i commented last repository maybe was mistake.
Comment 6 Zdeněk Pavlas 2012-12-03 02:44:40 EST

*** This bug has been marked as a duplicate of bug 870691 ***

Note You need to log in before you can comment on or make changes to this bug.