Bug 88270 - Exception not being handled for SSL.SysCallError
Exception not being handled for SSL.SysCallError
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-08 10:34 EDT by Arenas Belon, Carlo Marcelo
Modified: 2007-04-18 12:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 15:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2003-04-08 10:34:30 EDT
Description of problem:
an Exception of type SSL.SysCallError was received on the applet and reported as
a bug with a question mark icon

Version-Release number of selected component (if applicable):
2.0.9-0.9.0.1

How reproducible:
probably related to some maintenance on the RHN servers, i could try to block
the RHN servers and see if i can reproduce the error, but my guess is that i
could reproduce it re routing the RHN servers to a server not listening or
rejecting XMLRPC over HTTPS connections

Actual results:
Exception type SSL.SysCallError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 448, in refresh
    self.model.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line 264, in refresh
    self.__rpc_server__.refresh(force)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_rpc.py", line 84, in refresh
    status = server.applet.poll_status()
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
    verbose=self._verbose
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 130, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 614, in send_http
    headers=self.headers)
  File "/usr/lib/python2.2/httplib.py", line 701, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.2/httplib.py", line 723, in _send_request
    self.endheaders()
  File "/usr/lib/python2.2/httplib.py", line 695, in endheaders
    self._send_output()
  File "/usr/lib/python2.2/httplib.py", line 581, in _send_output
    self.send(msg)
  File "/usr/lib/python2.2/httplib.py", line 560, in send
    self.sock.sendall(str)
  File "/usr/lib/python2.2/site-packages/rhn/SSL.py", line 191, in write
    sent = self._connection.send(data)
SysCallError: (104, 'Connection reset by peer')

Expected results:
the usual "ok" icon

Additional info:
the problem was gone once i "reconfigure" the rhn-applet
Comment 1 Arenas Belon, Carlo Marcelo 2003-04-08 11:17:33 EDT
interesting also that just after the problem i got a report that my kernel was
not up2date as reported on bug #84757.

both problems disapeered once i right click on the applet and went thru the
"configure" process again

couldn't add this same comment to ticket #84757 tough as the ticket broken as
explained on bug #87920
Comment 2 Daniel Veillard 2003-04-08 12:41:04 EDT
Well it's an error connecting to the server, I doubt it's a registration
based problem. Are you using a free RHN slot or a paid one ? Anyway
I tried to make sure the exception will be properly caught in future
version of the rhn-applet package.

Daniel
Comment 3 Arenas Belon, Carlo Marcelo 2003-04-08 13:01:36 EDT
i am using a paid RHN slot (uuid=6931413a-6673-11d7-80a0-00d059543bd1).

after giving it some more thought, i think the problem should maybe better be
handled on the SSL.py package for rhnlib 1.0 where there is no exception
handling an SSL.SysCallError on the write method as it is currently being
handled on the read method, otherwise the SSL subsystem wouldn't give consistent
errors.

the problem couldn't be replicated just trying to fool rhnsd or blocking access
to the RHN server as the problem was presented while writing to the established
and authenticated SSL connection
Comment 4 Warren Togami 2003-04-11 18:20:46 EDT
This same error happened to me on Shrike.  I am a paid RHN customer.
Comment 5 Daniel Veillard 2003-04-11 18:29:42 EDT
The applet (nor the SSL layer) do not catch up all the connection errors,
however it tries to recover from them. Did the icon turned grey with an
interrogation mark (i.e. it got stuck in the error state) or did it indicated
a connection error (double arrow on grey background crossed with a red strike) ?
In the last case it will retry the connection automatically until it succeeds
and the error message is then purely informative.

Daniel
Comment 6 Arenas Belon, Carlo Marcelo 2003-04-11 20:06:15 EDT
as i reported initially i got an interrogation mark (AKA question mark), a gray
one indeed.

Comment 7 Bill Nottingham 2006-08-05 00:23:02 EDT
Red Hat apologizes that these issues have not been resolved yet. We do want to
make sure that no important bugs slip through the cracks.

Red Hat Linux 7.3 and Red Hat Linux 9 are no longer supported by Red Hat, Inc.
They are maintained by the Fedora Legacy project (http://www.fedoralegacy.org/)
for security updates only. If this is a security issue, please reassign to the
'Fedora Legacy' product in bugzilla. Please note that Legacy security update
support for these products will stop on December 31st, 2006.

If this is not a security issue, please check if this issue is still present
in a current Fedora Core release. If so, please change the product and version
to match, and check the box indicating that the requested information has been
provided.

If you are currently still running Red Hat Linux 7.3 or 9, please note that
Fedora Legacy security update support for these products will stop on December
31st, 2006. You are strongly advised to upgrade to a current Fedora Core release
or Red Hat Enterprise Linux or comparable. Some information on which option may
be right for you is available at http://www.redhat.com/rhel/migrate/redhatlinux/.

Any bug still open against Red Hat Linux 7.3 or 9 at the end of 2006 will be
closed 'CANTFIX'. Again, if this bug still exists in a current release, or is a
security issue, please change the product as necessary. We thank you for your
help, and apologize again that we haven't handled these issues to this point.

Note You need to log in before you can comment on or make changes to this bug.