Bug 883907 - [abrt] mate-session-manager-1.5.0-1.fc17: g_logv: Process /usr/bin/mate-session was killed by signal 5 (SIGTRAP)
[abrt] mate-session-manager-1.5.0-1.fc17: g_logv: Process /usr/bin/mate-sessi...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-utils (Show other bugs)
17
x86_64 Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
abrt_hash:cdef270908f5454d0568fcebfb5...
: Reopened
: 884306 884475 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-05 09:43 EST by Jeff Bastian
Modified: 2013-01-19 15:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 15:06:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (2.13 KB, text/plain)
2012-12-05 09:43 EST, Jeff Bastian
no flags Details
File: environ (1.11 KB, text/plain)
2012-12-05 09:43 EST, Jeff Bastian
no flags Details
File: backtrace (31.90 KB, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: cgroup (131 bytes, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: smolt_data (2.64 KB, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: executable (21 bytes, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: maps (21.46 KB, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: dso_list (4.28 KB, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: proc_pid_status (925 bytes, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: var_log_messages (1.10 KB, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details
File: open_fds (706 bytes, text/plain)
2012-12-05 09:44 EST, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2012-12-05 09:43:51 EST
Description of problem:
I updated to Mate 1.5 packages and now mate-session crashes when I try to login.

Version-Release number of selected component:
mate-session-manager-1.5.0-1.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        mate-session
crash_function: g_logv
kernel:         3.6.7-4.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 g_logv at gmessages.h:101
: #2 g_settings_set_property at gsettings.c:492
: #3 object_set_property at gobject.c:1352
: #4 g_object_constructor at gobject.c:1863
: #6 g_object_new_valist at gobject.c:1830
: #8 g_settings_new at gsettings.c:869
: #9 gsm_manager_init at gsm-manager.c:2336
: #10 g_type_create_instance at gtype.c:1892
: #11 g_object_constructor at gobject.c:1849
: #12 gsm_manager_constructor at gsm-manager.c:2100
Comment 1 Jeff Bastian 2012-12-05 09:43:54 EST
Created attachment 658228 [details]
File: core_backtrace
Comment 2 Jeff Bastian 2012-12-05 09:43:56 EST
Created attachment 658229 [details]
File: environ
Comment 3 Jeff Bastian 2012-12-05 09:44:01 EST
Created attachment 658230 [details]
File: backtrace
Comment 4 Jeff Bastian 2012-12-05 09:44:03 EST
Created attachment 658231 [details]
File: limits
Comment 5 Jeff Bastian 2012-12-05 09:44:07 EST
Created attachment 658232 [details]
File: cgroup
Comment 6 Jeff Bastian 2012-12-05 09:44:09 EST
Created attachment 658233 [details]
File: smolt_data
Comment 7 Jeff Bastian 2012-12-05 09:44:10 EST
Created attachment 658235 [details]
File: executable
Comment 8 Jeff Bastian 2012-12-05 09:44:12 EST
Created attachment 658237 [details]
File: maps
Comment 9 Jeff Bastian 2012-12-05 09:44:13 EST
Created attachment 658238 [details]
File: dso_list
Comment 10 Jeff Bastian 2012-12-05 09:44:15 EST
Created attachment 658240 [details]
File: proc_pid_status
Comment 11 Jeff Bastian 2012-12-05 09:44:17 EST
Created attachment 658242 [details]
File: var_log_messages
Comment 12 Jeff Bastian 2012-12-05 09:44:18 EST
Created attachment 658244 [details]
File: open_fds
Comment 13 Jeff Bastian 2012-12-05 09:53:56 EST
Hmmm, I seem to have a mix of 1.4 and 1.5 packages:

1.4:
mate-conf-1.4.0-21.fc17.x86_64
mate-conf-editor-1.4.0-2.fc17.x86_64
mate-conf-gtk-1.4.0-21.fc17.x86_64
mate-control-center-1.4.0-9.fc17.x86_64
mate-corba-1.4.0-9.fc17.x86_64
mate-desktop-1.4.1-11.fc17.x86_64
mate-desktop-libs-1.4.1-11.fc17.x86_64
mate-file-manager-1.4.0-12.fc17.x86_64
mate-file-manager-extensions-1.4.0-12.fc17.x86_64
mate-mime-data-1.4.0-10.fc17.noarch
mate-panel-1.4.0-12.fc17.x86_64
mate-power-manager-1.4.0-2.fc17.x86_64
mate-settings-daemon-1.4.0-6.fc17.x86_64
mate-system-log-1.4.0-3.fc17.x86_64
mate-system-monitor-1.4.0-2.fc17.x86_64
mate-terminal-1.4.0-4.fc17.x86_64
mate-text-editor-1.4.0-2.fc17.x86_64
mate-utils-1.4.0-3.fc17.x86_64
mate-vfs-1.4.0-14.fc17.x86_64
mate-vfs-smb-1.4.0-14.fc17.x86_64

1.5
mate-backgrounds-1.5.0-2.fc17.noarch
mate-calc-1.5.0-1.fc17.x86_64
mate-common-1.5.0-1.fc17.noarch
mate-dialogs-1.5.0-1.fc17.x86_64
mate-doc-utils-1.5.0-1.fc17.noarch
mate-file-manager-open-terminal-1.5.0-1.fc17.x86_64
mate-icon-theme-1.5.0-1.fc17.noarch
mate-image-viewer-1.5.0-2.fc17.x86_64
mate-keyring-1.5.0-2.fc17.x86_64
mate-keyring-pam-1.5.0-2.fc17.x86_64
mate-media-1.5.0-1.fc17.x86_64
mate-menus-1.5.0-1.fc17.x86_64
mate-menus-libs-1.5.0-1.fc17.x86_64
mate-notification-daemon-1.5.0-1.fc17.x86_64
mate-polkit-1.5.0-1.fc17.x86_64
mate-screensaver-1.5.1-1.fc17.x86_64
mate-session-manager-1.5.0-1.fc17.x86_64
mate-themes-1.5.0-1.fc17.noarch
mate-window-manager-1.5.2-7.fc17.x86_64
Comment 14 Dan Mashal 2012-12-05 10:38:31 EST
Yep. Give it some time while the 1.5 packages get pushed. Sorry for the delay. It takes longer to get to F17. The mail is slower delivering packages. :/
Comment 15 Dan Mashal 2012-12-05 10:40:21 EST
Can you do a yum update --enablerepo=updates-testing? I'm seeing all of the packages pushed to testing for 17
Comment 16 Jeff Bastian 2012-12-05 13:10:07 EST
The updates-testing packages are giving me problems:

--> Finished Dependency Resolution
Error: Package: mate-utils-1.4.0-3.fc17.x86_64 (@updates)
           Requires: libmate-panel-applet-2.so.1()(64bit)
           Removing: mate-panel-1.4.0-12.fc17.x86_64 (@updates)
               libmate-panel-applet-2.so.1()(64bit)
           Updated By: mate-panel-1.5.2-4.fc17.x86_64 (updates-testing)
               Not found

I added --skip-broken and it excluded:
Skipped (dependency problems):
 mate-panel                     x86_64   1.5.2-4.fc17   updates-testing   1.8 M
 mate-panel-libs                x86_64   1.5.2-4.fc17   updates-testing    33 k
 mate-power-manager             x86_64   1.5.1-3.fc17   updates-testing   3.0 M
Comment 17 Jeff Bastian 2012-12-05 13:15:52 EST
So it updated

mate-system-monitor-1.5.0-2.fc17
mate-calc-1.5.1-1.fc17
mate-control-center-1.5.1-1.fc17
mate-settings-daemon-1.5.4-1.fc17
mate-file-manager-1.5.2-1.fc17
mate-file-manager-extensions-1.5.2-1.fc17
mate-desktop-libs-1.5.5-1.fc17
mate-desktop-1.5.5-1.fc17

And now I can login again, but I get an error pop-up:
  "Clock" has quit unexpectedly.
and clicking Reload just fails again.

I suppose it needs the mate-panel updates also.
Comment 18 Dan Mashal 2012-12-05 13:23:41 EST
Yup. Thanks for the report. I'll look into it.
Comment 19 Jeff Bastian 2012-12-05 13:27:31 EST
I removed mate-utils and then I was able to update mate-panel and now everything works.  (Except, obviously, I'm missing some utilities.)
Comment 20 Dan Mashal 2012-12-05 13:29:16 EST
I'm in the process of rebuilding the package for F17.
Comment 21 Dan Mashal 2012-12-05 17:52:25 EST
*** Bug 884306 has been marked as a duplicate of this bug. ***
Comment 22 Fedora Update System 2012-12-05 23:13:08 EST
mate-utils-1.4.0-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-utils-1.4.0-5.fc17
Comment 23 Fedora Update System 2012-12-05 23:13:21 EST
mate-utils-1.4.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-utils-1.4.0-5.fc18
Comment 24 Fedora Update System 2012-12-05 23:13:33 EST
mate-utils-1.4.0-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/mate-utils-1.4.0-5.fc16
Comment 25 Dan Mashal 2012-12-06 11:36:13 EST
*** Bug 884475 has been marked as a duplicate of this bug. ***
Comment 26 Jeff Bastian 2012-12-06 11:56:18 EST
The new package (comment 22) has a conflict:

Transaction Check Error:
  file /usr/bin/mate-system-log from install of mate-utils-1.4.0-5.fc17.x86_64 conflicts with file from package mate-system-log-1.4.0-3.fc17.x86_64
  file /usr/share/applications/mate-system-log.desktop from install of mate-utils-1.4.0-5.fc17.x86_64 conflicts with file from package mate-system-log-1.4.0-3.fc17.x86_64

I removed mate-system-log and then mate-utils installed ok.

The mate-utils package should have an 'Obsoletes: mate-system-log' in the spec (if it truly obsoletes it)
Comment 27 Fedora Update System 2012-12-06 15:08:31 EST
Package mate-utils-1.4.0-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-utils-1.4.0-5.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19853/mate-utils-1.4.0-5.fc18
then log in and leave karma (feedback).
Comment 28 Chris Brennan 2012-12-17 08:51:02 EST
As of Dec. 12th 2012, I've run into this bug (and I just did an update over the weekend of about 400 packages, I assume MATE was one of the things to get updated. The only reason I was able to figure MATE crashing when I logged in was because abrt notifified me when I switched back to LXDE for now, just to get a GUI. Thankfully, none of my other WM's are broke.

The long and the short of this is it appears that MATE-1.5.x is still broke and it's been far longer then 2 days since the last update. Is there a fix for this?
Comment 29 Stuart D Gathman 2012-12-17 17:47:27 EST
You still get the crash immediately after updating, with the old version still running.  Just reboot and try MATE again.  Works For Me™ anyway.
Comment 30 Chris Brennan 2012-12-18 08:23:26 EST
A reboot makes things worse. mate-panel crashes and restarts instantly upon login, only way to stop it was to ctrl+alt+backspace to the login screen and swiched back to LXDE for now. 

What's next?
Comment 31 Stuart D Gathman 2012-12-18 12:14:22 EST
(In reply to comment #30)
> A reboot makes things worse. mate-panel crashes and restarts instantly upon
> login, only way to stop it was to ctrl+alt+backspace to the login screen and
> swiched back to LXDE for now. 
> 
> What's next?

Did you remove mate-system-log per comment#26?  It prevents mate-utils from updating.  Also, please report your mate-* versions if that isn't your issue.  Here are my working versions after to update to 1.5:

mate-backgrounds-1.5.0-2.fc17.noarch
mate-vfs-1.4.0-14.fc17.i686
mate-session-manager-1.5.0-1.fc17.i686
mate-panel-1.5.2-4.fc17.i686
mate-terminal-1.4.0-4.fc17.i686
mate-menus-1.5.0-1.fc17.i686
mate-desktop-libs-1.5.5-1.fc17.i686
mate-control-center-1.5.1-1.fc17.i686
mate-themes-1.5.0-1.fc17.noarch
mate-settings-daemon-1.5.4-1.fc17.i686
mate-notification-daemon-1.5.0-1.fc17.i686
mate-file-manager-1.5.2-1.fc17.i686
mate-corba-1.4.0-9.fc17.i686
libmate-1.4.0-17.fc17.i686
mate-power-manager-1.5.1-3.fc17.1.i686
mate-window-manager-1.5.2-7.fc17.i686
mate-polkit-1.5.0-1.fc17.i686
mate-conf-editor-1.4.0-2.fc17.i686
mate-menus-libs-1.5.0-1.fc17.i686
mate-dialogs-1.5.0-1.fc17.i686
mate-desktop-1.5.5-1.fc17.i686
mate-conf-1.4.0-21.fc17.i686
mate-text-editor-1.4.0-2.fc17.i686
mate-panel-libs-1.5.2-4.fc17.i686
mate-keyring-1.5.0-2.fc17.i686
mate-file-manager-extensions-1.5.2-1.fc17.i686
mate-mime-data-1.4.0-10.fc17.noarch
mate-icon-theme-1.5.0-1.fc17.noarch
mate-keyring-pam-1.5.0-2.fc17.i686
Comment 32 Chris Brennan 2012-12-18 19:14:24 EST
I don't appear to have mate-system-log (or mate-utils) installed. Here is the list of packages I have installed related to mate though:

[root@Phaëton ~]# rpm -qa mate-\*; rpm -qa libmate
mate-dialogs-1.5.0-1.fc17.x86_64
mate-text-editor-1.4.0-2.fc17.x86_64
mate-window-manager-1.5.2-7.fc17.x86_64
mate-desktop-libs-1.5.5-1.fc17.x86_64
mate-icon-theme-1.5.0-1.fc17.noarch
mate-corba-1.4.0-9.fc17.x86_64
mate-themes-1.5.0-1.fc17.noarch
mate-vfs-1.4.0-14.fc17.x86_64
mate-file-manager-1.5.2-1.fc17.x86_64
mate-terminal-1.4.0-4.fc17.x86_64
mate-session-manager-1.5.0-1.fc17.x86_64
mate-media-1.5.0-1.fc17.x86_64
mate-keyring-1.5.0-2.fc17.x86_64
mate-mime-data-1.4.0-10.fc17.noarch
mate-menus-1.5.0-1.fc17.x86_64
mate-desktop-1.5.5-1.fc17.x86_64
mate-notification-daemon-1.5.0-1.fc17.x86_64
mate-menus-libs-1.5.0-1.fc17.x86_64
mate-conf-editor-1.4.0-2.fc17.x86_64
mate-control-center-1.5.1-1.fc17.x86_64
mate-backgrounds-1.5.0-2.fc17.noarch
mate-conf-1.4.0-21.fc17.x86_64
mate-panel-libs-1.5.2-4.fc17.x86_64
mate-file-manager-extensions-1.5.2-1.fc17.x86_64
mate-settings-daemon-1.5.4-1.fc17.x86_64
mate-panel-1.5.2-4.fc17.x86_64
mate-keyring-pam-1.5.0-2.fc17.x86_64
mate-polkit-1.5.0-1.fc17.x86_64
libmate-1.4.0-17.fc17.x86_64
[root@Phaëton ~]# ls -lash /usr/bin/mate* | grep log
100K -rwxr-xr-x 1 root root  97K Nov 22 20:43 /usr/bin/matedialog
[root@Phaëton ~]#
Comment 33 Dan Mashal 2012-12-18 19:15:28 EST
Will update comps.
Comment 34 Stuart D Gathman 2012-12-19 10:18:37 EST
(In reply to comment #32)
> I don't appear to have mate-system-log (or mate-utils) installed. Here is
> the list of packages I have installed related to mate though:
> 
Looks ok to me.  Did you report the crash?  Does abrt add it here, or create a new crash bug?
Comment 35 Chris Brennan 2012-12-19 10:30:18 EST
(In reply to comment #34)
> Looks ok to me.  Did you report the crash?  Does abrt add it here, or create
> a new crash bug?

Abrt redirected me here as an existing bug. I can log into mate now, but mate-panel crashes and restarts very quickly. Making the WM unusable and my poor cursor goes off into seizure-land till I reset X. I can use my laptop, but w/ a different WM (fluxbox/LXDE/Gnome3 (ICK!)) for now.
Comment 36 Chris Brennan 2012-12-19 20:57:25 EST
OK, so .. MATE works (and the world is right again) ... but there is a problem. When I log in, no more seizures, but I got a completely reset desktop. All of my customizations are gone :(
Comment 37 Yaakov Selkowitz 2012-12-19 22:26:55 EST
(In reply to comment #36)
> OK, so .. MATE works (and the world is right again) ... but there is a
> problem. When I log in, no more seizures, but I got a completely reset
> desktop. All of my customizations are gone :(

I suppose this issue belongs in a new bug, but in the meantime, following up on discussion in #mate tonight:

In order for user settings to be carried over from MateConf to GSettings, .convert files need to be provided by each transitioning package.  The .convert files are 1:1 mappings of GSettings to MateConf keys, and are used by mateconf-gsettings-data-convert(1), which is launched by the session manager on startup (via .desktop file in /etc/xdg/autostart).

Unfortunately, it seems that these files have not been added to packages.  This needs to be done ASAP and IMO should be considered a BLOCKER for 1.5/1.6 in Fedora stable.

Here is an example of what needs to be done:
https://github.com/cygwinports/mate-image-viewer/commit/52ec275

This also means that, despite being deprecated, mate-conf MUST be shipped (with gsettings support) as part of @mate-desktop for the foreseeable future.
Comment 38 Dan Mashal 2013-01-19 15:06:42 EST
Comment #36 confirms that the original issue is fixed.

Comment #37 is being addressed upstream.

Note You need to log in before you can comment on or make changes to this bug.