Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 884238 - IOException: Input/output error during write on /dev/vda
Summary: IOException: Input/output error during write on /dev/vda
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b0005e534d414e308d2e3e012d5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-05 17:24 UTC by Roland Wolters
Modified: 2013-02-01 15:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-01 15:50:26 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb-zqyFmg (276.26 KB, text/plain)
2012-12-05 17:24 UTC, Roland Wolters
no flags Details

Description Roland Wolters 2012-12-05 17:24:20 UTC
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-zqyFmg
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Wed 05 Dec 2012 06:23:11 PM CET
version:        17

anaconda-tb-zqyFmg: Text file, 282887 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 221, in commitToDevice
:    return self.__disk.commit_to_dev()
:  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 32, in new
:    ret = fn(*args, **kwds)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 286, in commitToDisk
:    self.partedDisk.commitToDevice()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 429, in execute
:    self.device.disk.format.commitToDisk()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 320, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 375, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:IOException: Input/output error during write on /dev/vda

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:TZ=Europe/Berlin
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:DISPLAY=:1
:LVM_SUPPRESS_FD_WARNINGS=1
:LIBUSER_CONF=/tmp/libuser.vxzCA9
:PWD=/
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:method=http://mirror2.hs-esslingen.de/fedora/linux/releases/17/Fedora/x86_64/os/

Comment 1 Roland Wolters 2012-12-05 17:24:39 UTC
Created attachment 658306 [details]
File: anaconda-tb-zqyFmg

Comment 2 Roland Wolters 2012-12-05 17:32:07 UTC
The bugtrace occured, when I tried to install Fedora 17 in a VM with virt-manager runnning under Fedora 18. The installation failed when it tried to write the changes to the disk.

The disk is a lv volume on the running Fedora 18.

A similar behaviour appeared when I tried to install a CentOS 6 - so it might be that the Bug is actually related to Fedora 18 and not Fedora 17 !

Comment 3 Chris Lumens 2012-12-05 18:31:29 UTC
Something's definitely wrong with writing to your hard drive, which anaconda can't do anything about.  From your syslog:

17:23:01,912 ERR kernel:[  387.361450] end_request: I/O error, dev vda, sector 0
17:23:01,912 ERR kernel:[  387.361765] end_request: I/O error, dev vda, sector 0
17:23:02,023 ERR kernel:[  387.472132] end_request: I/O error, dev vda, sector 0

Comment 4 Roland Wolters 2012-12-06 09:43:10 UTC
Hej Chris, thanks for looking into this. And yes, its right that the disk seems to be a problem. But, keep in mind that this is the error of the virtual machine guest. The disk is nothing else than what virt-manager provides.

So I wonder if there are problems with the VM environment, with the VM host itself - and thus with virt-manager (or libvirt, or what not) in Fedora 18, which was the VM host.

Any idea how to track what is going on on the host machine or on the host libvirt environment?

Comment 5 Justin M. Forbes 2013-02-01 15:50:26 UTC
This bug is being closed because it has been set needinfo for more than 2 weeks without a response. If this is still an issue, please reopen and reply with the requested information.


Note You need to log in before you can comment on or make changes to this bug.