Bug 88437 - 4.0.12 is latest version
4.0.12 is latest version
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: mysql (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
http://www.mysql.com
: FutureFeature
: 112856 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 22:14 EDT by acount closed by user
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-11 12:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-04-09 22:14:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.-
2.-
3.-
    

Additional info:
Comment 1 Patrick Macdonald 2003-04-11 12:06:08 EDT
We will not be moving to MySQL 4.x in the near future. There are other
components in the distro that depend on our current release level of MySQL
(3.23.56).

Here's a snippet from http://www.mysql.com/downloads/mysql-3.23.html.

"This is the current stable release of the MySQL database server. It is
recommended for most users."
Comment 2 acount closed by user 2003-04-11 12:23:02 EDT
and there is more here  : http://www.mysql.com/downloads/index.html

* MySQL database server & standard clients:
o MySQL 4.0 -- Production release (recommended)
[...]
o MySQL 3.23 -- Older production release

;-)
Comment 3 Patrick Macdonald 2003-04-11 12:28:48 EDT
Very true... point taken.

However, as stated, there are other packages/components that we have to worry
about.  It's not that we'll never move to 4.x, just not in the near future.
Comment 4 acount closed by user 2003-04-11 12:34:42 EDT
the problem is 3.xx was declared obsolete and _only_ critical bug fixes will be
fixed

http://www.mysql.com/doc/en/MySQL_4.0_In_A_Nutshell.html

"MySQL Version 4.0.12 was declared stable for production use in March 2003. This
means that, in future, only bug fixes will be done for the 4.0 release series
and only critical bug fixes will be done for the older 3.23 series. See section
2.5.3 Upgrading From Version 3.23 to 4.0."


and too at front page http://www.mysql.com

MySQL Version 4.0 Dubbed “Production”
MySQL AB, developer of the world's most popular Open Source database, today
announced that the MySQL™ database version 4.0 has been labeled “production,”
indicating that it is ready for any MySQL deployment. To reach production
status, MySQL software must pass a series of rigorous tests with no fatal bugs
and then undergo “battle-testing” in live environments for a minimum of three
months. Starting with the newest release, 4.0.12, MySQL version 4.0 is now the
standard code base for all MySQL database downloads.

Comment 5 Patrick Macdonald 2003-04-11 13:46:48 EDT
Yes, 4.0 was declared stable for production.  However, as stated, the other
packages/components depend on 3.23.x version.  This will change over time.

The MySQL folks have been releasing a version of 3.23 every few months.
http://www.mysql.com/doc/en/News-3.23.x.html

    * D.4.1 Changes in release 3.23.57 (not released yet)
    * D.4.2 Changes in release 3.23.56 (13 Mar 2003)
    * D.4.3 Changes in release 3.23.55 (23 Jan 2003)
    * D.4.4 Changes in release 3.23.54 (05 Dec 2002)
Comment 6 Guðmundur D. H. 2004-01-05 05:00:40 EST
*** Bug 112856 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.